1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clarification before I buy a psp?

Discussion in 'Sony PSP - Mod and firmware discussion' started by bondage81, Feb 8, 2007.

  1. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    Hey guy's I am a noob and I have read threads upon threads and just want to get clarification on some things before I buy a psp.

    1. What is the latest version of firmware a psp can have without having to use a gta lsc 2.0 to run iso's,emulators,and homebrew stuff?

    2. What is the purpose of gta lsc 2.0 other than the 2.0 firmware update on it. Do you have to use it everytime to load certain thing or is it a one time use?

    3. Will the 3.03 OE-C custom firmware let me play everything as fas as iso's, emulators, ripped movies, and are there any features that this custom firmware disables? (I've seen some threads say they were loseing their internet connection)

    4. If I use the 3.03 OE-C firmware will I have to use dev hook or anything eles to play my homebrew or back up copies of my ps1 games and psp backed up cso files?

    5. What is the differance between oe-a, oe-b, and oe-c custom firmware? I assume oe-a and b are older versions and c is the best?


    Guy's thank you for helping all of us newbs out here and I GREATLY appreciate it and look up to you all!!!

    thanks, Jon
     
  2. BlkMagic1

    BlkMagic1 Regular member

    Joined:
    Jun 19, 2006
    Messages:
    1,847
    Likes Received:
    0
    Trophy Points:
    46
    if you read a lot of threads you should know that the 3.03 will let you play iso from the ms and psx games(pops)
     
  3. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    I am a little slow when it comes to some of this stuff. Like I said before I haven't even bought a psp yet but I am going to and I am not sure what ms and the pops are. I am sorry for sounding like a dumb ass, I just basicly want a break down on what I can and cant do with the latest firmware.
     
  4. BlkMagic1

    BlkMagic1 Regular member

    Joined:
    Jun 19, 2006
    Messages:
    1,847
    Likes Received:
    0
    Trophy Points:
    46
    ms is memory stick with the latest firmware you cant really do anything unless you have a ps3 really but if you get between 1.5-3.03 you can either downgrade or go to 3.x oe series
     
  5. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    so if i get a psp between 1.5-3.03 I can downgrade to 1.5 then upgrade to oe-c and play new umd games and all iso's, homebrews,and ps1 rips. What is the latest version between 1.5-3.03 I can buy that i don't have to have gta lcs to downgrade it?
     
  6. cmoney91

    cmoney91 Regular member

    Joined:
    Nov 19, 2006
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    26
    1. the latest is DAX's 3.10oe-a and it will allow you to load iso's,emulators,and homebrew stuff.

    2.the purpose of getting gta lsc with the 2.0 update is because it is the unpatched version (the patched version is 2.6 i think) so it allows you to run unsigned code hence the downgrader for firmwares 2.81-3.03.

    3.yes it will do it all the only thing it disables is the location free player. Plus using this firmware it allows you to make movies at the psp's full resolution at 480x272!!,and i have 3.03oe-c and my internet works perfectly fine.

    4.nope it loads them straight from the xmb/psp menu.

    5.Your right. a,b,c are just different builds of the firmware version meaning c is the latest and greatest. LOL.
     
  7. cmoney91

    cmoney91 Regular member

    Joined:
    Nov 19, 2006
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    26
    if you get a firmware under 2.80 you dont have to buy gta lsc to downgrade just get the downgrader from here and downgrade
     
  8. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    is DAX's 3.10oe-a better than the 3.03 OE-C Winstaller that I found on a thread I think hexitnow started?

    What versions of firmware can I go with to be able to downgrade and upgrade to a custom firmware without having to use gta lcs?
     
  9. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    Thanks alot!!! You have been a great help!!!
     
  10. cmoney91

    cmoney91 Regular member

    Joined:
    Nov 19, 2006
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    26
    firmware versions 1.5-2.80 are all downgradeable without gta lcs.
    DAX 3.10 good but if you want to use custom icons like in my sig 3.03 will do it 3.10 will brick
     
  11. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    Will DAX's 3.10oe-a let you play the latest umd games as well? and can you send a link to the site to download it. Is DAX's 3.10oe-a fairly reliable? Thanks so much!
     
  12. BlkMagic1

    BlkMagic1 Regular member

    Joined:
    Jun 19, 2006
    Messages:
    1,847
    Likes Received:
    0
    Trophy Points:
    46
    well no umd went over 2.81 yet so yea but i suggest you go for 3.03 oe-c because there are still a few bugs in 3.10 oe-a
     
  13. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    Great! You are a wise and great psp god!!! Thanks again!
     
  14. hexitnow

    hexitnow Active member

    Joined:
    Jun 18, 2006
    Messages:
    6,109
    Likes Received:
    0
    Trophy Points:
    96
    edited out
     
    Last edited: Feb 8, 2007
  15. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,832
    Likes Received:
    33
    Trophy Points:
    78
    Exept from No-UMD working (which wasn't mentioned in any readme, that to 3.00 OE-A (I think) just said it was disabled), I didn't find any so far. When you're in Europe and want to play PAL PSX-games in your language, you should go to 3.10 OE-A' (OE-A2), the PSX-emulator in 3.03 just supports NTSC-games, meaning you have to use the sometimes not working PAL-NTSC-fix.
     

Share This Page