1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

completely lost :o(

Discussion in 'Sony PSP - Mod and firmware discussion' started by loz2502, Feb 9, 2007.

  1. loz2502

    loz2502 Member

    Joined:
    Feb 9, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    hallo.
    i recently found out about the whole playing ps1 games on psp and wanted to give it a go. its all so flippin complicated though. basically i got as far as putting the game (oddworld) on my psp but then it just says i have to activate the system before i can play it. i dunno what its sayin really but im guessing its probably something to do with the firmware. i reads up about it n theres loads of stuff about downgrading to version 1.50...but mines on 3.11 :eek:s is it even possible for me to do it or should i just give up? all i wanna do is play oddworld :eek:(
    fanks
     
  2. hodgins91

    hodgins91 Regular member

    Joined:
    Jun 10, 2006
    Messages:
    3,636
    Likes Received:
    0
    Trophy Points:
    46
    well you cant downgrade to 1.5 sorry :( but you should be able to play that game as your running the official 3.11 firmware
     
  3. stevenps2

    stevenps2 Regular member

    Joined:
    Apr 13, 2006
    Messages:
    1,543
    Likes Received:
    0
    Trophy Points:
    46
    no you cant play it unlees you had dark alex's firmware,which you dont so sorry,dunno how you could of upgradeded to 3.11 tho?
     
  4. ggbarnum

    ggbarnum Regular member

    Joined:
    Apr 14, 2006
    Messages:
    1,432
    Likes Received:
    0
    Trophy Points:
    46
    He can play it, he just needs a PS3 to activate the feature on his PSP.

    [edit] oh and the game has to be officially available from the Sony download shop of course :)
     
    Last edited: Feb 9, 2007
  5. loz2502

    loz2502 Member

    Joined:
    Feb 9, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    i think i have 3.11. i just went on the network update on my psp and it updated to 3.11 *shrugs*. if i download dark alex's firmware will i be able to play the game? coz i tried to once but i wasnt really sure what i was downloadin or what to do with it. n i aint buyin a ps3.
     
  6. badblud

    badblud Regular member

    Joined:
    Oct 3, 2006
    Messages:
    158
    Likes Received:
    0
    Trophy Points:
    26
    no therre isnt a 3.11 downgrader out yet.u got to wait awhile.
     

Share This Page