1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

confused

Discussion in 'Sony PSP - Mod and firmware discussion' started by bertyn, May 5, 2011.

  1. bertyn

    bertyn Member

    Joined:
    Nov 24, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    16
    Ok this might be long but i got a couple of questions.

    I bought a used psp slim 2000 from gamestop and I was going to hack it but luckily me it was already. So right now the cfw for it is 5.00 m33-6 and I have the kingdom hearts umd from my friend but i cant play it because its telling me I have to upgrade to 6.20 or higher. I looked at the forums and found out about Prometheus-4 but is it only for iso's and UMDs or just iso's only?

    Now if I have to upgrade my cfw which one is the best one out there?
     
  2. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,831
    Likes Received:
    33
    Trophy Points:
    78
    Just update to 6.38 ME v2 and you won't have any problems anymore.
    http://www.psp-hacks.com/file/2082
     
  3. b1gh3ad

    b1gh3ad Regular member

    Joined:
    Nov 7, 2010
    Messages:
    980
    Likes Received:
    0
    Trophy Points:
    26
    or 6.20 PRO-B5 Permanent
     

Share This Page