1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

converting avi to mpeg

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by gdh, Feb 21, 2003.

  1. gdh

    gdh Guest

    can anyone help with me with a problem, some avi's which i've tried converting to mpeg the picture is perfect but the sound is about 1 or 2 second out. i'm using tmpge and virtual dub, but for some reason i cannot get picture and sound perfect.
    has anyone any ideas how to fix this problem. i would be grateful to know
     
  2. FIXIT

    FIXIT Regular member

    Joined:
    Mar 4, 2002
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    26
    open tmpgene in the mpeg settings under the advanced tab double click source range one of the settings is audio gap correct set this to 200 and set the start frame and end frame so that you are only encoding 2 or 3 mins of footage to test then run tmpgenc if this makes the gap worse set audio gap correct to - 200 and then try again it may take a few goes at altering the audio gap setting to get the right value when you find the right value encode the whole movie with that setting
     
  3. gdh

    gdh Guest

    thanks for your reply fixit, the one thing i forgot to mention is that the sound delay only happens about 1/2 way through the film, should i still try what you suggested or would this mean doing something different.
     
  4. FIXIT

    FIXIT Regular member

    Joined:
    Mar 4, 2002
    Messages:
    201
    Likes Received:
    0
    Trophy Points:
    26
    this wont work because it will shif the audio all the way through the film one way to get round this is to split the movie at the point it goes out of synch, then do what i said for the second half, you could use avi splitter to split the file but ive personally never used it
     
  5. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    gdh, when you use virtualdub are you saving a wav and then loading it into tmpgenc?? well if you are i would advise against it. instead do the following to de-compress the audio

    open the avi in virtualdub
    click video - direct stream copy
    click audio - full processing mode
    click audio again and click compression. select no compression pcm and click ok
    click file - save as avi

    the saved file will be bigger than the original but TMPGEnc will have a better chance at keeping the sound in sync!
     

Share This Page