1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Copying DVDs and not being able to see the hard coded subtitles...

Discussion in 'DVD Shrink forum' started by vladtepes3176, Nov 19, 2010.

  1. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    I have been ripping and copying DVDs for several years now. But something has me completely confused and I was hoping someone had some info. I rip DVDs with DVD decrytper most of the time. I have also used DVD Fab. Both work fine. But I recently I bought Bram Stoker's Dracula The Collectors Edition (a 2008 DVD) and went to copy it to the hard drive.

    Anyone familar with the film knows that in the begining of the movie there are English "forced subs" for the Romanian speaking dialog between Gary Oldman and Anthony Hopkins. It's famous when Oldman says "The blood is the life and it shall be mine!"

    And no matter how I ripped it to the computer with either devise these subtitles do not show up. When you play the DVD itself in a DVD player it displays the subtitles I am speaking of. Does anyone know why this is happening or am I overlooking something? I have tried ripping it without removing the RCE potection and still the same thing. If someone could give some input I would really appreciate it. I want to make a copy with those subtitles hardcoded into the copy as they are a part of the English version of the film. Thanks for your attention to this.
     
    Last edited: Nov 19, 2010
  2. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    I did use DVD shrink to make a back up copy. But ripping the DVD to the hard drive I used Dvd Decrypter and tried DVD Fab as well. Both rips when played back on the computer do not show the forced subtitles.

    Is there a way to rip the DVD and include the forced subtitles? If so what software would be best?

    The other thread I posted about this was closed. I didn't mean to multi-post, I registered for the site, and made the mistake. Sorry. Anyway, any help you could offer would be greatly appreciated.
    Cheers
     
  3. Chetwood

    Chetwood Regular member

    Joined:
    Nov 26, 2005
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    If the subs are not hardcoded but only a seperate stream that is forced (usually recognized in Shrink by being quite small) there is no way to make it hardcoded without reencoding the movie. You can however take that particular stream and turn it to on in re-author mode. Still any standalone will overwrite this settings so you might have to turn them on manually.
     
  4. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for your reply. I have tried re-ripping the video with DVD decrypter in IFO mode, still the subtitles are not present. Would you recommend using DVD decrypter for ripping the DVD to the hard drive in order to somehow get the forced subtitles, if so in what mode would be best?
    Shrink in re-author mode allows you to choose a subpicture stream. So would I have to choose "English" and then proceed? I tried that when I re-ripped in IFO mode, and in the Shrink preview widow the subtitles did not show. I do want to re-encode the move to avi, but want the forced subtitles included. For backing up the DVD itself, and somehow including the forced subtitles would I have to re-encode first, say make an Mp4 of the DVD with handbrake, and then may a DVD of that? Sorry, I am really confused with this issue. I have actually read a lot and tried different methods without success. Thanks for your help.
     
  5. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    I need to know if there is a way to rip forced subtitles when ripping a DVD that is in English, and appear only for the non-speaking English parts of the film, as in "Bram Stoker's Dracula The Collector's Edition." (2008 release)

    Before I purchased the DVD I downloaded copies of BR rips of the film all from trusted, well known sources, three different rips actually, and none of them had the subtitles that appear in the film for the Romanian speaking parts. However the older DVD release of the film, which I think is a 97 DVD Release has them hard-coded, so they appear in the rip.

    I have tried all methods for doing this. I have followed guides, read forums, threads, used Dvd Decrypter in FILE & IFO mode to decrypt the film, still the subtitles do not show. Used DVD Fab, nothing. I have used Shrink in re-author mode, and still noting. If I choose English sup-picture in re-author mode they show for the WHOLE FILM not just for the Romanian parts as they should.

    I need to know if someone could help me do this, and by help I mean provide a step-by-step guide exactly how to do it. There are a lot of people online if you Google struggling with the same issue, so if you have done this successfully before, and could proved a guide to how you did this, it would be great, and would certainly help me, and everyone else that has this problem!

    My end goal is to:
    1. Make a back-up copy of the DVD with the forced subtitles included in the rip.
    2. To make a rip, to xvid or another format (I have been using AutoGK to do this with all my other rips) that include the forced-subtitles for the Romanian speaking parts of the film.

    Thank you very much,

    Thanks, please help.
    Cheers,
     
  6. Chetwood

    Chetwood Regular member

    Joined:
    Nov 26, 2005
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    Shrink's preview window never shows subtitles and DVD Decrypter is totally outdated. Your best bet is to rip the movie with DVDfab in main movie mode with ALL subs included. Usually forced subs are a seperate (small) stream which are set to forced in the DVD but apparently it's also possible to have items with a forced flag inside the regular stream.

    If it's not the latter in your case, play back the ripped disc in PowerDVD without subs on. The stream selection menu should show the forced stream selected. Now open the disc in Shrink and identify this stream by it's position among the other streams.

    If this fails you can rip all subs with VSrip into idx/sub and open those in SubtitleCreator which will show you the text of the subs. That way you can identify which of the english streams translates what's spoken in Romanian.
     
  7. malynch69

    malynch69 Member

    Joined:
    Nov 1, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    11
    What are you using to play the backups? Are you burning them to disc and using a DVD player are are using a media player and playing from the hard drive? I believe that the forced subtitles are ripped and your media player may not support them (I know VLC does NOT support forced subtitles).
     
  8. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    I ripped the film with DVDFab with all subs included as you recommended. I then played the ripped files back with PowerDVD as suggested with sub-titles off. Note: Also Secondary subtitles are set to off. When doing this the English subtitles for the Romanian Spoken Parts of the film DO SHOW as they should.

    You go on to talk about identifying the stream for Shrink. This is where I need further help. I don't know how to proceed exactly from here since both Primary and Secondary Subtitles in Powerdvd are set to off and the subs I want to show during playback DO SHOW PROPERLY.
    How would I proceed?
    Thanks for all your help. I am trying to work through this.
     
  9. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    Hi, I am doing both, burning to disc and playing them back on computer. I have used VLC to play them on computer and yes the subs I want to see do not show. The burned disks that I rip I play on a DVD player and they do not show as well. I just tried ripping the Bram Stoker's Collector's Edition Disc with DVDFab in main movie mode, with all the subs included and played the ripped files with PowerDVD. With the Primary and Secondary Subs set to:OFF the English subs for the Romanian parts of the film ARE VISIBLE as they should be. Now I need to find out how to use Shrink to incorporate these titles into a rip. I also need to make a smaller Xvid copy of the film as will the the English subs for the Romanian parts included.
     
  10. Chetwood

    Chetwood Regular member

    Joined:
    Nov 26, 2005
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    Even with a greyed out subtitles menu in PowerDVD you can see all streams present and the order they are in. This is the exact order they are listed in DVD Shrink. Since the subs are not hardcoded into the video, one stream should be selected in this greyed out menu. Simply check it's position and select the corresponding stream in DVD Shrink.
     
    Last edited: Nov 23, 2010
  11. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    In Powerdvd under: DVD (button)- Select Main Menu: ALL Sub-menus are grayed out including: "The Subtitle Menu" and No information can be viewed from any grayed out menu heading.
    The other menus under DVD (button) including Primary Subtitles and Secondary Subtitles are "white" and you can view the different choices for subs. But they are both set to "off" and the Romanian Subs are visible during playback. I don't see how it is possible to choose a particular one of Shrink, in Re-author mode it gives the option to "Display the following sub-picture" I have tried this before and if you choose "English" the English subs are displayed throughout the entire film, not just for the Romanian speaking parts.

    I have tried shrink since my last post and viewing the files using PowerDVD with subtitles set to "off" the Subtitles I want appear. I will now try to burn a copy and see what happens.
    Am I missing a step?
     
  12. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    I didn't mention that when I used Shrink it was in "No Compression" Mode and after the process the files played the English subs for the Romanian speaking parts of the film with PowerDVD. I am now trying to use Shrink to compress the film to a DVD-R size and see if the subs will show.
     
  13. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    I was successful in making a DVD copy with Shrink that featured the English Subtitles for the Romanian Spoken dialog of the film! I burned the disk to a DVD-R and it played on the computer with PowerDVD (which displayed the English subs for the Romanian Speaking parts of the film) and on my LG Dvd player which also displayed the subs correctly. Thank you very much for the help.

    Now I need to make a 1.3 GB rip of the film to Xvid (or other format if necessary) containing these subs for the Romanian Speaking parts of the film in the rip. Do you know the best way to proceed? I have always used AutoGK for creating Xvid rips.
    Thank you for your attention and needed help for my problem.
     
  14. Chetwood

    Chetwood Regular member

    Joined:
    Nov 26, 2005
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    Rip main movie in Shrink with NO compression and ALL subs. Open it in AutoGK and include the sub for romanian which will then be muxed into the video OR use external subs so these subs can be turned off.
     
  15. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    I did the above, I meant to write about it today earlier. I was up till four in the morning messing around.

    I tried AutoGK but it failed. I tried it five times, selecting the stream the forced subs were in, under the "Subtitles Tracks" menu, then in "advanced settings", checking Display only forced subtitles. I read this online, following an AutoGK tutorial, tried, but it failed in the beginning of the process. The error referenced "vobsub" having a problem.

    Then I used DVDSUBEDIT to identify which stream had the forced subs, and it is a great tool, but then I read that it could not "hard code" any subs into a rip.

    Finally I then used Handbrake, to make an MP4 rip of the film, and was able to have the forced subtitles hard coded onto the rip, by going into the subtitles menus, checking "Forced Only" and using the "Foreign Audio Search" Pull down menu to select, in this case "English (Bitmap) that featured the forced subs to show on the rip. I then used the "Preview" feature and caught a part of the film showing the forced subs, so I knew it was going right.

    I encoded the film to a 1.3GB MP4 that featured the English subs for the Romanian speaking parts of the film hard coded onto the rip. Only thing after it was processed it came out as m4v file, which I was surprised at, because whenever I had used Handbrake before to encode the file result was always Mp4. However I had never made a rip from a TS folder before. I read how M4v is for apple, which I didn't know because I never use anything Apple, but read it was essentially the same as Mp4, so I just had to change the file extension. But it came out well.

    Still, I would like to know why AutoGK failed. It has never failed on me before, but I had never used this subtitle feature. Do you have any ideas? I would try again to achieve an xvid rip of the film, so I could accomplish it for future rips. I still have the DVD ripped by Fab and Shrink in full, on my HD.
    Hey, thank you for all your help with this!
    Cheers,
     
  16. Chetwood

    Chetwood Regular member

    Joined:
    Nov 26, 2005
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    Since such an old movie most likely only has CSS protection I don't see why AutoGK should have any trouble. Apart from identifying forced subs that is. So you have to UNCHECK this option and select the forced sub you identified before as the only stream. When "use external subtitles" is also unchecked AutoGK will hardcode this stream into the video.
     
  17. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    Hi, First I did make a rip with AutoGK with the "English Letterbox" subtitle track checked which DVDSUBEDIT showed me the "forced subs" were located. They were flagged I believe, in the window of DVDSUBEDIT they were labeled as "forced"
    I made this first rip without the "Display only forced subtitles" and "Use external subtitles" checked. The result was a rip of the film that had English subs throughout the entire film, not just for the Romanian speaking parts as I had wanted. I also tried a similar rip with the "English Wide" subtitles selected which DVDSUBEDIT also told me the "forced subs" were located and the same thing happened. That's when I tried a rip with the "Display only forced subtitles" checked and got the failed message.
    What do you think might be the problem?
    Thanks
     
  18. Chetwood

    Chetwood Regular member

    Joined:
    Nov 26, 2005
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    That you still haven't identified the forced stream despite what you wrote earlier. I can't help you any further cause I don't have the DVD.
     
  19. vladtepes3176

    vladtepes3176 Member

    Joined:
    Nov 19, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    No, I have identified where they are located as I wrote, in the English Letter Box and English Wide Subtitles Streams. But AutoGK does not recognize them as being forced. If I select either of the above subs then English subs are encoded for the entire film, not for the just the Romanian speaking parts.

    In handbrake it is clear, and finds the subs with the "Forced Subs" box checked, and that encoding went fine. AutoGK does not. Maybe because it's a new release, as you mentioned. I am didn't know AutoGK had trouble with new releases. If that is the fault of AutoGK then there is nothing I can do with it. There is no single stream to identify that only has the "forced subs" for the film. They are located within the main English subs for the film.

    As I mentioned a followed an official AutoGK tutorial to rip the film by choosing the subtitle stream the forced subs were in and then checking "Display only forced subtitles" and according to that tutorial it should have worked but it failed in the beginning of the process siting a Vobsub error.

    I tried to do it the way you suggested but as I mentioned subs were included for the entire film. There is no other way of using AutoGK to identify forced subs. So that's what I was asking about. I wasn't saying I didn't know where the subs were located, so sorry for the confusion.
     
  20. Chetwood

    Chetwood Regular member

    Joined:
    Nov 26, 2005
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    Apparently this is one of the subs where the forced items are inside the regular stream and have a forced flag. Haven't got anyone of those yet. So your best bet is to search for HandBrake-0.9.3 the last version that outputs to xvid/avi or use Staxrip instead.
     
    Last edited: Nov 26, 2010

Share This Page