1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

could it be my burner's fault why i am having trouble getting discs to play?

Discussion in 'DVDR' started by jetsetter, Nov 5, 2004.

  1. jetsetter

    jetsetter Member

    Joined:
    Oct 28, 2004
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    16
    hey,
    i was just wondering.. i have tried about 5 different media types on my LiteOn SOHW-1213S and a few of them play on one of my dvd players but NONE of them play on any other dvd players i've tried. it is getting really annoying. there's like a 75% chance that the disc wont play on any standalone. i am using DVD Shrink/Nero combo and the discs burn fine but they simply dont play on just about every standalone i've tried. could it be my burner??
    also, just yesterday i received a batch of "Ritek" G04's from www.shop4tech.com since i heard they were quite good. i am wondering if they are fakes cos they don't play either on any of my standalones. the disc will start up and then just fail. there is no mention of the brand Ritek (or any brand for that matter) anywhere on the discs or spindle. they are simply a silver matte finish with purple dye.
    if anyone could give me some insight on the above topics, it'd be greatly appreciated. im begininng to think it's my LiteOn burner, and not the media, that's causing the headaches. thanks in advance!
     
  2. sly_61019

    sly_61019 Senior member

    Joined:
    Jun 28, 2003
    Messages:
    9,522
    Likes Received:
    0
    Trophy Points:
    116

Share This Page