1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Could you please help mee??

Discussion in 'Sony PSP - Mod and firmware discussion' started by Sale_17, Sep 19, 2007.

  1. Sale_17

    Sale_17 Member

    Joined:
    Sep 19, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I have a PSP with 3.50 firmware and i would like to downgrade it to version 1.50. I used lots of downgraders but everywhere you need Lumines game. I downloaded it and it is in .iso file. I tried to get it on my psp but the psp won't recognise it and it writes corrupted file when I try to open it...
    Would you help me I'm desperate already.

    Thank you very much!
     
  2. OcelotRev

    OcelotRev Member

    Joined:
    Sep 19, 2007
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    11
    hey you need the acual game itself becasue your psp does not reconise .iso's yet and you need the game luminis or gta then upgrade to 3.55m33 i think then you can play .iso's.
     

Share This Page