1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Digital TV quality

Discussion in 'Digital TV - UK & Europe' started by myoldhk, May 14, 2011.

  1. myoldhk

    myoldhk Member

    Joined:
    Feb 6, 2009
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    16
    Hi Guys
    Im posting here coz in Australia we use PAL also.
    I have a problem with my digital reception from my Antenna. Every time i flick on a light for some reason I get a serge through the Antenna Booster brand Kingray.
    The Tv is a Toshiba LCD 46" NEW, this problem has been occuring for a while now and already stuffed one TV.
    I called the antenna guy and I got an answer of get rid of the fluro lights, and a quote for 800 bucks to replace pretty much everything from antenna to wall socket.

    Before this I swapped out the booster/ amplifier for a standard splitter and that was poor quality but no flickering.

    Any Ideas???? The reception is better and the flickering a bit less but not stopped. All power runs 230/240v in Australia.
     
  2. e45

    e45 Regular member

    Joined:
    Jun 5, 2009
    Messages:
    4,336
    Likes Received:
    0
    Trophy Points:
    46
    did you check the connections on the cable for outer copper cable touching the inner part of the cable only a thought also maybe have your power for your antenna going direct to socket if it is try an extension lead
     
  3. fintannl

    fintannl Regular member

    Joined:
    Feb 11, 2009
    Messages:
    1,834
    Likes Received:
    7
    Trophy Points:
    48
    i use a surge protector for all my tv gear. aint that expensive to buy but if you bought expensive tv equipment an absolute necessity. have all gear connected to a belkin surgemaster. never failed me yet
     
  4. myoldhk

    myoldhk Member

    Joined:
    Feb 6, 2009
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    16
    I have surge protectors and all cables were double checked if touching outer wire to inner core. The antenna guy even said not reccomended to use serge protecters, now thats crap.
    The only thing I can put it down to is maybe a dodgy booster its nearly 10 years old.
    Thanks guys
     

Share This Page