1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DivX: audio problems

Discussion in 'DivX / XviD' started by Oudis, Jan 30, 2011.

  1. Oudis

    Oudis Member

    Joined:
    Dec 28, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Hello everybody,

    Not long ago I bought a DivX-compatible DVD player. I use Nero to burn the videos as data DVDs; the result is, generally speaking, good; however, many times the resulting DivX video is almost inaudible.

    I’ve searched the net and found that the problem is very common; there are many posts about this problem, most of them very old. I’ve tried the solution everybody suggests (VirtualDub) and it doesn’t work: I keep getting “error” messages.

    Is there any easier, way to boost the audio on a DivX file? Or even before I turn the video into a DivX file, can I boost the audio of an AVI file? Another way that doesn’t involve VirtualDub? Another software, maybe newer, something simpler?

    As you can probably see, I am by no means a computer expert, I started to burn videos last week… I have a Toshiba laptop, Windows 7, a (legal) copy of Nero; and please remember I burn the videos on a DVD so that I can watch them on a DVD player.

    If you need to know anything else about what I use please let me know.

    Thanks a lot; I would appreciate any suggestion.

    Oudis.
     
  2. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,515
    Likes Received:
    29
    Trophy Points:
    128
    Increasing the volume using VirtualDub is relatively easy - most other methods that work involve demuxing the video and audio and remuxing them together.


    Can you run down the steps you use with VirtualDub and post the error.
     
  3. Oudis

    Oudis Member

    Joined:
    Dec 28, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Hello Attar,

    And thanks for replying. Since I posted my question I’ve kept on working. The error I used to get was “Error 100”; it happened almost every time I tried to boost the audio of an .avi file. Then I started to combine subtitles and video in a .divx file through AVIAddSubs, which got rid of the problem, and then opened the resulting file with VirtualDub; but I get other errors.

    This is what I’ve been doing so far:

    1- I select the .divx video whose audio I want to boost.

    2- I open it with VirtualDub. Here I usually get the first warning:

    “AVI: Stream 2 has an invalid sample rate. Subtituting 15 samples/sec as a placeholder.”

    Usually (90% of the time) I also get a second warning:

    “AVI: Variable bitrate (VBR) audio detected. VBR audio in AVI is non-standard and you may encounter sync errors up to 39479ms when attempting to extract WAV files or playing in some players. If this is a problem, use Full Processing mode is recommended to decompress or recompress the audio. (This warning can be disabled in Options, Preferences, AVI bitrate: 111.3+-13.8 kbps)”

    The numbers change from video to video but the message is usually there.

    3- I click OK and go to Video and select Direct Stream Copy; I go to Audio and select Full Processing Mode.

    4- Then I go to Compression, I choose DivX Audio, I click in “Show all formats” and select one of the four choices I have, usually the last one (the tutorial I’m following doesn’t say which compression option to choose):

    32 kbps, 22 kHz, stereo for DivX, 4KB/s
    20 kbps, 22 kHz, stereo for DivX, 3KB/s
    64 kbps, 32 kHz, stereo for DivX, 8KB/s
    64 kbps, 44 kHz, stereo for DivX, 8KB/s

    5- The I go to Audio and select Volume, click on “Adjust volume of audio channels”, and increase it.

    6- Then I save it as AVI.

    When I open the files, I sometimes find the audio is saturated and have to do the whole process again. I can do it easily, so that’s not the problem; the problem is that audio and video are not synchronized anymore, despite the fact that I’ve used “full processing mode”.

    Thanks for your patience, and sorry for the long explanation. Any ideas? Any way to avoid this problem? Can I change the bitrate of the file at the beginning, for instance?

    Oudis
     
  4. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,515
    Likes Received:
    29
    Trophy Points:
    128
    Can you download MediaInfo and drag a file onto it and post the image - like this.
    Or list the codec information.

    [​IMG]
    hosting images
     
  5. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,515
    Likes Received:
    29
    Trophy Points:
    128
    BTW, are you using VirtualDub or the old VirtualDubMod?
     
  6. Oudis

    Oudis Member

    Joined:
    Dec 28, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Hello again Attar,

    I’ve downloaded MediaInfo, and opened an AVI file with it –the same file of the previous example; this is the information it gave me (I selected this option since it’s easier to post, let me know if it’s OK):

    ----------------------------------------------
    General
    Complete name : C:\Users\XXX\Desktop\XXX.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    File size : 703 MiB
    Duration : 1h 24mn
    Overall bit rate : 1 170 Kbps
    Writing application : VirtualDubMod 1.5.4.1 (build 2178/release)
    Writing library : VirtualDubMod build 2178/release

    Video
    ID : 0
    Format : MPEG-4 Visual
    Format profile : Advanced Simple@L5
    Format settings, BVOP : 1
    Format settings, QPel : No
    Format settings, GMC : No warppoints
    Format settings, Matrix : Custom
    Codec ID : XVID
    Codec ID/Hint : XviD
    Duration : 1h 24mn
    Bit rate : 1 046 Kbps
    Width : 720 pixels
    Height : 304 pixels
    Display aspect ratio : 2.35:1
    Frame rate : 25.000 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Compression mode : Lossy
    Bits/(Pixel*Frame) : 0.191
    Stream size : 629 MiB (89%)
    Writing library : XviD 1.2.1 (UTC 2008-12-04)

    Audio
    ID : 1
    Format : MPEG Audio
    Format version : Version 1
    Format profile : Layer 3
    Mode : Joint stereo
    Codec ID : 55
    Codec ID/Hint : MP3
    Duration : 1h 24mn
    Bit rate mode : Variable
    Bit rate : 111 Kbps
    Nominal bit rate : 128 Kbps
    Channel(s) : 2 channels
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 66.9 MiB (10%)
    Alignment : Aligned on interleaves
    Interleave, duration : 24 ms (0.60 video frame)
    Interleave, preload duration : 419 ms
    Writing library : LAME3.98r
    Encoding settings : -m j -V 4 -q 2 -lowpass 17 --abr 128
    Language : English

    -----------------------------------------------

    I opened the file with VirtualDub (not VirtualDubMod) again just in case, and got the same message:

    “AVI: Variable bitrate (VBR) audio detected. VBR audio in AVI is non-standard and you may encounter sync errors up to 39479ms when attempting to extract WAV files… (etc.)”

    Is this what you asked me to do? Is it useful? And thanks again,

    Oudis
     
  7. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,515
    Likes Received:
    29
    Trophy Points:
    128
    I've seen this when the file had a subtitle added to it with AviAddXsubs - VirtualDub doesn't recognize it.
    I don't know if this applies in your case - but if you have been adding subtitles with AviAddXSubs, it should be done after using VirtualDub .

    This isn't an error - more of a heads up.
    I find that AVI files using VBR audio, when played on my standalone players, give out of sync and video breakup.
    Change it to CBR audio using the Lame mp3 codec.
    If it's installed in your PC, it should be selectable from the VirtualDub Audio menu.

    When creating AVI files I make a point of setting the audio to CBR.


    http://users.tpg.com.au/mtam/install_lame.htm

    Save the video as Direct Stream Copy as usual.

    You can check the volume level, by pressing the 'Output' playback button on the lower left of the pane.


    [​IMG]
    image upload
     

Share This Page