1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Do I Have To Reflash Drive To Stock To Play Original Games With Xgd3

Discussion in 'Xbox 360 - Modding & Hacking' started by bixby454, Oct 4, 2011.

  1. bixby454

    bixby454 Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Hey I asked this on some other site and did not get a good answer. My xbox 360 dashboard version is too old to play XGD3 games and I want to play dark souls.

    I am thinking about just buying the game but people are telling me I well still need to reflash my drive to stock. And I have no way of doing this.

    Is it true that even if I pay for the game I still have too open the xbox up and pay some money for stuff just to put it back to stock?

    Can't I just buy it and update it with the game, I don't care if I can play backups anymore.
     
  2. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    Recent dashboard updates for the 360 have flashed the DVD drive's firmware to a new stock firmware.

    So, if you buy the original of Dark Souls and update your 360's dashboard via the game disc, one of two things will happen: -

    1. Your 360 will be updated to a new dashboard and you'll be able to play all original games just fine, but your drive will be flashed to a new stock firmware and it will no longer play backups.

    2. When you try and update via the game disc, your 360 will get stuck in an update loop or you'll get an error. That said, this usually happens when people are trying to update using a backup, not an original.

    2 is why it's recommended to flash back to stock before performing a dashboard update, but if you want to risk it (as it's usually updating from a backup that causes problems, not an original game disc) then that's up to you.
     
  3. bixby454

    bixby454 Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Damn I don't want to buy the game for 60$ just to have it error out on me, not like I can return it now ah days.

    Is there anyone that knows for 100% if a original copy of Dark Souls well just put me back too stock firmware? Or if it well kill my xbox?
     
  4. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    If you are on dashboard version 2.0.12625.0 or earlier, then Dark Souls will definitely flash your drive back to stock.

    As for whether it will "kill your Xbox", I think that's highly unlikely as the problems people have been having are because they used a backup to update their 360, not an original, but I can't say with 100% certainty that nothing untoward will happen so you'll be trying it at your own risk.
     
  5. bixby454

    bixby454 Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    I have dashboard version 2.0.13146.0 well I be ok with this version
     
  6. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    2.0.13146.0 flashes most fat 360s with a new stock firmware. If you have a fat 360 and you can still play backups, then maybe the drive in your 360 is one of the few that's not reflashed by the update.

    If you have a slim 360, then it's 2.0.13599.0 (the current dashboard update) that reflashes drives with a new stock firmware.
     
  7. bixby454

    bixby454 Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Yes im using the old white fat one and still able too play backups, do you think I can just download a copy of dark souls and play it then? Or is the XGD3 still going to stop me?
     
  8. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    XGD3 backups will not boot unless your 360 is flashed with LT+ 2.0, which I assume yours is not as the firmware was only just released.

    Also, some of the latest games also require you to install a dashboard newer than the one that's installed on your 360.

    If it was me, I'd just buy it (in fact I have - it should be here by Friday hopefully :)) and try playing it, but as I said - even though I think you'll be fine, you're doing that at your own risk.
     
  9. Modking30

    Modking30 Regular member

    Joined:
    Feb 16, 2010
    Messages:
    3,169
    Likes Received:
    0
    Trophy Points:
    46
    how many threads do we need on the same topic? Search people!
     
  10. bixby454

    bixby454 Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    One last thing on this funksoulb, if I buy it and update firmware with the game.

    Well my fat xbox 360 still be able to play backups, or was it just the 2.0.13146.0 my xbox was able too by pass?
     
  11. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    I don't know to be honest. If you have a fat 360 and it's on dashboard version 2.0.13146.0 (or later) then that's the one that should have flashed it back to stock, but I don't think all drive types are reflashed, so I'm guessing that that's why you can still play backups.
     
  12. bixby454

    bixby454 Member

    Joined:
    Oct 4, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    I think I just wasted 65$ I just looked at what my friend had installed on my xbox and I see driver san francisco on it.

    Is that not a XGD3 game, does that mean I could have just downloaded a copy of dark souls or is there other versions of driver san francisco?
     
  13. ParadoXIII

    ParadoXIII Member

    Joined:
    Nov 10, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    ok. So i have LT+ 2.0.13599.0 and i am trying to play a backup copy of dark souls. game shows up in dashboard but when i try to play it, it says "requires update" game cannot be played without update. Am i doing something wrong? i've been searching everywhere and can't find an answer.
     

Share This Page