1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Do I HONESTLY need 1.50 for Open Edition

Discussion in 'Sony PSP - Mod and firmware discussion' started by OWNaruto, Jun 1, 2007.

  1. OWNaruto

    OWNaruto Guest

    Okay, I have a 3.40 firmware PSP, and I wanna get Open Edition. Is there any way to do it without 1.50 firmware? DAX's readme for it says I need like 1.50 Custom Firmware and then update it...I really wanna get stuff like homebrew...so I will try anything to get the Open Edition, except for opening it or bricking it <_<.

    (PS I am new, but I have been browsing the forums for a few months, so...yeah.)
     
  2. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    Only 1.50 :(
     
  3. mrmcman

    mrmcman Guest

    or a previous custom firmware...
    if ur good at modding, u should look into this. it would save time on downgrader, ud only need a supercharged HEN
     
  4. OWNaruto

    OWNaruto Guest

    Yeah, I suck at modding. I don't even know what a HEN or whatever is.
     
  5. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    HEN=Homebrew Enabled. nuff said!
     

Share This Page