1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

do I need Gta to downgrade 3.03 to 1.50??

Discussion in 'Sony PSP - Mod and firmware discussion' started by bluejet, Jul 26, 2007.

  1. bluejet

    bluejet Regular member

    Joined:
    Oct 1, 2005
    Messages:
    573
    Likes Received:
    0
    Trophy Points:
    26
    do I, because i dont have it. If I cant, can I still play emulators on 3.03?
     
  2. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    3.03 cant use emualtors or homebrew, and you need GTA to downgrade, or upgrade to 3.50, and downgrade with unpatched Lumines.
     

Share This Page