1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Do I need to upgrade firmware?

Discussion in 'Xbox 360 - Modding & Hacking' started by VITAL715, Jul 23, 2011.

  1. VITAL715

    VITAL715 Member

    Joined:
    Oct 20, 2009
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    I'm reading up on FAQs, but most of this stuff is overwhelming. I haven't played or followed discussion for more than a year so sorry in advance.

    So most of my games are wave 6 and I had been using activate iso to boot them up. Just curious if I can keep doing this for newer games or if I will ultimately have to reflash/upgrade firmware. (I think my firmware is 1.6 liteon?).

    Just curious because I read the AP25 faq on another website and it said the games require LT+ to play but I actually have fable 3 and it works.

    Would appreciate any help / info that will get me up to date.
     
  2. coorva

    coorva Regular member

    Joined:
    Apr 17, 2005
    Messages:
    1,239
    Likes Received:
    0
    Trophy Points:
    46
    you do need to update if you want to play the newer games,it would be LT 1.9 for liteons
     
  3. VITAL715

    VITAL715 Member

    Joined:
    Oct 20, 2009
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    Ok thanks. So I guess that fable 3 copy I have may not be fully compatible then.
     
  4. Modking30

    Modking30 Regular member

    Joined:
    Feb 16, 2010
    Messages:
    3,169
    Likes Received:
    0
    Trophy Points:
    46
    On the new dash this game will still not boot since it is a ap2.5 game. You have to wait on patches.
     
  5. VITAL715

    VITAL715 Member

    Joined:
    Oct 20, 2009
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    Oh gotcha. So people are able to patch AP2.5 games to work on older dashes?

    I'm just trying to avoid reflashing again because my computer had issues when I did it couple years ago.

    Thanks again for any help.
     
  6. Modking30

    Modking30 Regular member

    Joined:
    Feb 16, 2010
    Messages:
    3,169
    Likes Received:
    0
    Trophy Points:
    46
    Yes as long as you are on an older dash you can boot all games. Patches should be out any day for the ap2.5 games now. They have been looked at by Teamx and news is expected any day
     
  7. VITAL715

    VITAL715 Member

    Joined:
    Oct 20, 2009
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    Thanks so much for confirmation. Glad I'm not forced to update then.
     
  8. Modking30

    Modking30 Regular member

    Joined:
    Feb 16, 2010
    Messages:
    3,169
    Likes Received:
    0
    Trophy Points:
    46
    Only if you want to play on xbox live do you need to update.
     
  9. VITAL715

    VITAL715 Member

    Joined:
    Oct 20, 2009
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    Sorry to bump this topic again but my friend and I are a little confused on this...

    The AP2.5 faq said "My dashboard version is older than these but my drive supports AP25 - will I be affected? Not directly, but many games require a minimum dashboard version to work. The required System Update is on the disc. Some of these required dashboard versions are actively implementing AP25 for specific games."

    So far I understood if I stay on my current dashboard, I can play all games. But what if a game in the future forces me to update, THEN what would I have to do? Is it possible to patch these games to prevent the force update? Is this what you mean when you say "Patches should be out any day for the ap2.5 games now"???

    (We play offline only so please disregard LIVE)

    Thanks again
     

Share This Page