1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

do you know what chip do you need for your console?

Discussion in 'PS2' started by santy, Dec 19, 2004.

  1. santy

    santy Member

    Joined:
    Nov 27, 2004
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    16
    what's up man?
    my playstation 2 is SCPH - 50001, and I want to buy a swap magic disc, so the one I see on internet says "PS2 Version 1 - 10 Compatible" , so I want to know y that one works for my Playstation 2?
     
  2. devilhunt

    devilhunt Active member

    Joined:
    Aug 30, 2003
    Messages:
    3,367
    Likes Received:
    0
    Trophy Points:
    66
    not realy sure what your asking but a scph 50001 is a v9/10 ps2 and swapmagic 3.3 will work on a v1 to v12 ps2 and swapmagic 3.2 will work for v1 to v10 ps2
     
  3. santy

    santy Member

    Joined:
    Nov 27, 2004
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    16
    thanl you dogg, you just answered my question
     

Share This Page