1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Double check this for me?

Discussion in 'Sony PSP - Mod and firmware discussion' started by baronfun, Jan 8, 2007.

  1. baronfun

    baronfun Member

    Joined:
    Jan 8, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I just got a psp, but i think it was bought in november.
    Heres what I know

    -The original firmware had no web browser as far as I know
    -I got Me and my Katamari yesterday, and updated to 2.0
    -Inside the umd slot, there is nothing obviously on the right side, on the left, hidden and upside-down, it reads "1C6001"
    -I do not want to lose my only way to play Katamari, and don't have money to buy a new psp if this one bricks, but would like to play .iso files. (ps1 games would be really cool, too)

    I've read a ton on here, and from what i can tell it would be safe to do some kind of downgrade, but i guess the question i have is:

    Is there any important details I'm overlooking, what is my best/safest option (straight to 1.5, or up to 2.71, then down to 1.5), and do I need a GTA disk? because i dont have one.
     
  2. blade003

    blade003 Guest

    if your original firmware had no web browser then it could have been a 1.5. your best bet is to upgrade to 2.71 then downgrade to 1.5 then go to 3.03 OEA'

    with 2.71 downgrader you don't need the GTA disk
     
    Last edited by a moderator: Jan 8, 2007
  3. smlvfx

    smlvfx Regular member

    Joined:
    Dec 9, 2006
    Messages:
    1,358
    Likes Received:
    0
    Trophy Points:
    46
    Last edited: Jan 8, 2007
  4. jordsy27

    jordsy27 Member

    Joined:
    Dec 2, 2006
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    16
    id say to use the 2.0 - 1.5 mph downgrader it so simple i have used it 6 times no bricking get onto QJ and download mph dongrader then id say get 2.71 se-c as im not acutually too fond of this 3.03 oe-a & A'
     
  5. blade003

    blade003 Guest

    i know he does not have to downgrade but i used the 2.71 downgrader and it was very easy to do so that was my suggestion.
     
  6. baronfun

    baronfun Member

    Joined:
    Jan 8, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I may have been wrong, but I upgraded because i felt like it said i had to in order to play Katamari. If I downgrade, is there a way for me to play it still?
     
  7. smlvfx

    smlvfx Regular member

    Joined:
    Dec 9, 2006
    Messages:
    1,358
    Likes Received:
    0
    Trophy Points:
    46
    yes its compatible with the custom firmware

    http://eazyx.ea.funpic.de/index.php?action=home

    but i dont no how the custom firmware works because i dont have it i still have device hook 0.51
     
    Last edited: Jan 8, 2007

Share This Page