1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Downgrading of the PSP, nid help

Discussion in 'Sony PSP - Mod and firmware discussion' started by funnypsp, Mar 20, 2007.

  1. funnypsp

    funnypsp Member

    Joined:
    Feb 18, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    ok lets say i bought a new psp and the custom (original) FW is 2.80...can i downgrade it to 1.5 without bricking my psp???
     
  2. paul91

    paul91 Regular member

    Joined:
    Sep 27, 2006
    Messages:
    970
    Likes Received:
    0
    Trophy Points:
    26
    well its never 100% definate that u wont brick your PSP as there is always a chance of bricking. u have to make sure that the motherboard is not a TA-082 coz the 2.80 downgrader wont work. if thats the case then u will need to upgrade to 3.03 first then downgrade.
     
  3. funnypsp

    funnypsp Member

    Joined:
    Feb 18, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    so ure saying update to 3.03 first then downgrade straight to 1.5???
     
  4. Thoatih12

    Thoatih12 Regular member

    Joined:
    Nov 20, 2006
    Messages:
    703
    Likes Received:
    0
    Trophy Points:
    26
    yes if you have a unpatched Gta:liberty city stories..
     
  5. funnypsp

    funnypsp Member

    Joined:
    Feb 18, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    wat unpatched GTA?? so LETS SAY there is a 3.11 dg.....do i have to downgrade it to 3.03 first or dg straight to 1.5??
     
  6. paul91

    paul91 Regular member

    Joined:
    Sep 27, 2006
    Messages:
    970
    Likes Received:
    0
    Trophy Points:
    26
    *ignore this post*
     
    Last edited: Mar 20, 2007
  7. paul91

    paul91 Regular member

    Joined:
    Sep 27, 2006
    Messages:
    970
    Likes Received:
    0
    Trophy Points:
    26
    there is no 3.11 downgrader but if there was then u would need to go to 1.5
     
    Last edited: Mar 20, 2007
  8. Thoatih12

    Thoatih12 Regular member

    Joined:
    Nov 20, 2006
    Messages:
    703
    Likes Received:
    0
    Trophy Points:
    26
    3.11=no downgrader!
    3.03=downgrader via GTA:Liberty city stories
    2.80=downgrader..
    2.71=downgrader(ta one to)
    and basically every other one... theres your answer.. some need GTA:Liberty city stories (unpatched) to work and some dont..
     
  9. funnypsp

    funnypsp Member

    Joined:
    Feb 18, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    hey guys is dark alex's 3.10OE suitable for TA-082 board?
     
    Last edited: Mar 21, 2007
  10. paul91

    paul91 Regular member

    Joined:
    Sep 27, 2006
    Messages:
    970
    Likes Received:
    0
    Trophy Points:
    26
    yes ALL custom firmware's will work on a TA-082 mobo
     

Share This Page