1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duo2 SE Problem

Discussion in 'PS2 - Hardware boot discussion' started by jboo, Oct 26, 2004.

  1. jboo

    jboo Member

    Joined:
    Oct 26, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Hey I have been soldering for quite some time, and my recent attempt at a PS2 mod with a Duo2 SE modchip has been unsuccessful. I have reviewed all my solder points and they look clean, and have good contact. When I start up the PS2 everything works, fine, except no games will load (including original games). I either get the red screen that asks you to insert a PS2 compatible disc, or it goes to the browser window and shows the disc, but fails to load it. I know i am booting the games using the proper methods. My question is, could this be a problem with my solder for the power to the chip? Is the chip not activating properly? Are there any other suggestions?
     
  2. ronw1975

    ronw1975 Guest

    I would just suggest taking the mod chip out and clean your contacts off with rubbing alch and put back together and see if it works. If it does then you know its a prob with your mod chip or install... And try again or get another mod chip... if you can take that one back? Well doesnt seem like to many ppl respond around here I am no expert but will try and put my two cents in wherever i can! Good luck
     
  3. ronw1975

    ronw1975 Guest

    jboo, weird you should have this thread and I replied before I have finished my first ps2 mod. I am having the exact same problems. I also have v7 and nothing will load. I get insert ps2 disk or browser screen everytime. I also sometimes get a read disk error when i hit x button. And it loads mem card fine. I'm thinking maybe the laser has dust on it or something stupid/or install problem. I double checked all the connections going into the dvd player and looks fine. Any other opinions would be appreciative as I am by far no expert:)
     
  4. JBear504

    JBear504 Member

    Joined:
    Nov 20, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    i just installed the duo2se on my ps2,, when i first started it up i got a blank black screen and my eject button wouldnt work but the power button did and it read my memory card fine, i tore it back apart and looked at ALL my soderpoints!! what i found was that some wires were sticking out of the soder and therefore not making a good connection.. i went back resodered those, resodered my modchip power wire and put it all back together,, now everything is fine! also check your ID strips,, make sure they are connected in the slots very tight, if not it could be causing the prob. of the disc read error, the ID farthest back is what sends and recieves info. from the mother board and the laser,, make sure thats connected good as well.. my eject works, and it loads up like it normally would. good luck
     

Share This Page