1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dvd burner problem need help

Discussion in 'DVD / Blu-ray drives' started by Eric1987, May 17, 2007.

  1. Eric1987

    Eric1987 Member

    Joined:
    Apr 1, 2007
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    16
    I have a IO magic dvd burner that i purchased about a year ago and well when i installed it in the computer it was working amazing for a long time and lately i been having problems with it well this is the driver name and all from what i get off the stats from dvdinfopro

    BENQ DVD DD DW1620
    Firmware revision- B7C9
    Loader type-Tray
    Buffer size-2048KB
    Volume levels-2
    Connection interface-Atapi / IDE
    Drive interface-Atapi-3
    Region code-1
    Region control-RPC-2
    User changes left-4
    Vendor changes left-4

    I never updated the firmware or flashed the drive cuz i didnt wanna mess it up and destroy it so i never did any of that but the problem is that everytime i seem to burn a disk it does not burn at the speed i set it at usually burns it at a slower pace and there for i am getting alot of crc read errors in the disk and i thought the problem was nero but i was told it wasnt and i dont know what to do about it any suggestions?
     
  2. Eric1987

    Eric1987 Member

    Joined:
    Apr 1, 2007
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    16
    Also i forgot to mention this is a 16x burner and well i burn all my media at 8x cuz if i set it any higher it has tons of errors in it and at 8x it sometimes for the most part comes out fine but its not really burning at 8x cuz to burn a 4 gig dvd at 8x 11,080kb/s it takes the burner 16 minutes to complete that sounds really wrong to me i was thinking about it and was like that aint right should only take around 7-8 minutes at the most and i was told the media i was using wasnt so good but its not the media cuz i tried all media disks and well still the same problem
     
  3. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    I have the same drive. IO Magic except I crossflashed mine to be recognized a a genuine BenQ DW 1620. What exact problems are you having? Can you give me a unified list of your questions so I can more easily answer them?
     
  4. Eric1987

    Eric1987 Member

    Joined:
    Apr 1, 2007
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    16
    Yeah i set my burner speed to 8x and all my media is being only burned at 2x and if i set the speed to higher then 8x it will have read errors in the disk and and i searched for a program to give me info on my drive and this is what it says

    Drive region locked-YES and my firmware i never flashed the drive could it be that my firmware is old that is causing this problem to happen the firmware version is B7C9
     
  5. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
  6. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66

Share This Page