1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DVD Drive only reads certain DVDs

Discussion in 'DVD / Blu-ray drives' started by Terilon, Mar 8, 2007.

  1. Terilon

    Terilon Member

    Joined:
    Mar 8, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Forgive me if this is posted in the wrong section, obviously im new here, browsed the site for files and info thats helped me but never needed to post.

    I have a problem i cant figure out.

    My DVD drive used to work fine, no problems at all, im originally from england now living in USA, i brought over a few english DVD's (region 2) which worked fine in my PC for a while.

    I guess at somepoint between reformatting PC, Burning files and updating drivers/firmware ive messed something up.

    Now hardly any DVD's will play regardless of region.. ive tried varioes firmware and programs to fix, even doing a complete factory restore on pc, nothing seems to work.. a Region 2 dvd that worked when i first got my pc no now longer works, u can hear the drive spinning but nothing happens.

    If anyone can help me with this on what to check for, what to download.. this has really got me confused, even trying the LtnRPC program to remove region etc, still did nothing.

    Hardware:

    LITE-ON DVDRW SOHW-1633S
    Drive date: 7/1/2001
    Driver Version: 5.1.2535.0

    Sorry if this is a long post, ive been on other forums and it sucks when ppl ask for help and say my pc is broke help.. with no info for u to help them with :)
     
  2. JVC

    JVC Active member

    Joined:
    Apr 11, 2004
    Messages:
    2,121
    Likes Received:
    0
    Trophy Points:
    66
    I also use a LiteOn 1633s, and like it a lot. Try this:
    Go into your Device Manager, and find your drive. Right click on it, and choose "Uninstall". After it uninstalls, reboot, and let Windows detect new hardware, and install new a driver for you.

    Also, when you were doing all that stuff you did, the firmware possibly got corrupted. Go here, and get the newest firmware for it:
    http://codeguys.rpc1.org/firmwares.html
    It's about halfway down the page.
    Good luck!
     

Share This Page