1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dvd playback kit not working

Discussion in 'Xbox - General discussion' started by pong3, Jul 13, 2003.

  1. pong3

    pong3 Guest

    Whenever I put in my burned copy of Fast and the Furious, which is on a dvd-rw, a message comes up that says "the dvd region of your dvd playback kit receiver is invalid. remove disc to continue."
     
  2. Matador

    Matador Regular member

    Joined:
    Jul 3, 2003
    Messages:
    370
    Likes Received:
    0
    Trophy Points:
    26
    When burning video make sure that ur DVD burner is set to same region as the Xbox...
     
  3. pong3

    pong3 Guest

    I have no idea what you mean, if you can please explain.
    Also, when i put the movie in, i get no picture, then when i press play on the remote, it says the message.
     
    Last edited by a moderator: Jul 14, 2003
  4. Matador

    Matador Regular member

    Joined:
    Jul 3, 2003
    Messages:
    370
    Likes Received:
    0
    Trophy Points:
    26
    Go to device manager..find ur drive and go to properties. then dvd region...have you tried using CloneDVD by elby...
     
  5. pong3

    pong3 Guest

    what program do i need to go into to do this? No, i havent tried clonedvd yet.
     
  6. Matador

    Matador Regular member

    Joined:
    Jul 3, 2003
    Messages:
    370
    Likes Received:
    0
    Trophy Points:
    26
    right-click on "My Computer" and go down to Manage>device Manager...Thats in 2000/XP.98SE/ME go to right-click on "My Computer">Properties you will be in SYSTEM PROPETIES.>Hardware Tab...in the middle of the window is the Device Manager.
     
  7. pong3

    pong3 Guest

    I am talking about on the xbox man, i think your talking about the computer...sorry for any confusion, but if you know of a solution just post.
     

Share This Page