1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EAC/LAME slow, please help a newbie

Discussion in 'Audio' started by alxdotnet, Oct 21, 2003.

  1. alxdotnet

    alxdotnet Guest

    Hi, I just d/l'd EAC & LAME. Trouble is, EAC averages 4x rip speed, and LAME converts at about 1.3x, it also likes to drop often to .003x or so, please help.
     
  2. tigre

    tigre Moderator Staff Member

    Joined:
    Feb 18, 2003
    Messages:
    790
    Likes Received:
    0
    Trophy Points:
    26
    Last edited: Oct 21, 2003
  3. alxdotnet

    alxdotnet Guest

    I'm using pretty much default settings...192kbps VBR, LAME external encoder.(although my drive supports C2). After fixing one problem involving disk access, EAC runs at 20x or so on my 2.4Ghz laptop. The problem is Lame, which will sometimes stall at .02-.2x and just sit there for several minutes.
     
  4. tigre

    tigre Moderator Staff Member

    Joined:
    Feb 18, 2003
    Messages:
    790
    Likes Received:
    0
    Trophy Points:
    26
    Strange... I never get these extreme speed differences. Lame.exe (v. 3.90.3 here) encodes at 2-3x speed here using --alt-preset standard - Athlon 1300MHz here. What version do you use? (v. 3.93.1 should be ok too) Is it possible that your laptop is busy otherwise - or that some energy saving feature kicks in? You can check the former using e.g. Taskmanager while lame is running (preferably at too low speed).

    To increase speed (at decreasing quality) you could use:
    --alt-preset fast standard (4-5x speed here)
    -r3mix (5-6x speed)
    For more details about recommendable lame commandlines have a look at the sticky thread here. For setting up lame.exe as external encoder with EAC (if you haven't already) this guide is helpful: http://www.cd-rw.org/articles/archive/mydeneaclame.cfm
    (Most important: putting %s %d after your commandline, e.g. --alt-preset fast standard %s %d)
    [edit]
    Even higher speeds (and lower quality) you can get using CBR, e.g. -b 192 (~ 16x here). Using the -q switch you can adjust speed (and quality) additionally, e.g. -b 192 -q 2 (higher values = faster).
    [/edit]

    If speed is still too low you might want to use gogo for encoding. It's a speed-optimized older lame version. Quality is somewhat worse than lame's but it's faster. You can get it at http://rarewares.hydrogenaudio.org.

    If portable/standalone support isn't important for you you can use Musepack (.mpc) as encoding format. Quality-wise it's the best lossy encoder for bitrates >128kbps ATM. At "standard" setting (~170kbps) it's far better than mp3 even at 320kbps and encoding is quite fast (8-10x here). A guide how to set it up with EAC: http://rex-guide.de.vu ("standard" setting should be enough, no need to use "extreme", "insane" or even higher).
     
    Last edited: Oct 23, 2003
  5. alxdotnet

    alxdotnet Guest

    Well, i solved it. Thanks for the help. Turns out the antivirus software was running when the computer idled, accessing the disk and slowing Lame way down.
     

Share This Page