1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

English Subtitles in KillBill2 and Hidalgo

Discussion in 'DVD±R for advanced users' started by ngoti8tor, Sep 19, 2004.

  1. ngoti8tor

    ngoti8tor Member

    Joined:
    Dec 15, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    I've backed up KillBill2 and Hidalgo, but when I watch the back up's on TV, the English Subtitles do not show up when the people talk in foreign languages.
    I've tried copying with all the subtitles, but it still does not work. Can anyone help me out?
    Bill
     
  2. castun

    castun Member

    Joined:
    Jul 29, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    If you're using DVD Shrink to compress and backup, that is a problem I've noticed before as well, but with Band of Brothers. It does the opposite thing however. It shows foreign subtitles even with subtitles turned off. The originals don't have that problem.

    I get the feeling that even when doing a full copy (no reauthoring or deleting subtitles) that it doesn't properly save the state of certain subtitles and when they're supposed to be used.
     
  3. StanH1000

    StanH1000 Regular member

    Joined:
    May 19, 2004
    Messages:
    718
    Likes Received:
    0
    Trophy Points:
    26
    I have done both KillBill 1 and KillBill 2 using DVD Shrink in the re-author mode. There are TWO choices for English subtitles. The smaller contains the subtitles needed only when Chinese or Japaneese is spoken and the larger choice is for the entire film. Therefore, you must check the box for the smaller English soundtrack before doing the "backup" and Burn. Then when playing the movie on Set top DVD player or on computer, the subtitle must be activated from a Power DVD menue or from the remote (for the set top player). The subtitles then come on when needed!
     
  4. ngoti8tor

    ngoti8tor Member

    Joined:
    Dec 15, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    Thanks Stan,
    I copied them earlier with the English subtitle on it, but the problem you helped me with was that I had to physically turn on the subtitle with my remote control.
    When I played the original, there was no need to do this, as the English subtitles automatically came on.
    Thanks again Stan, you solved my problem.
    Bill
     
  5. kringles

    kringles Regular member

    Joined:
    Jul 7, 2004
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    26
    In the shrink reauthor mode you can right click on the main title, select 'set default streams...', and then select the audio and subpicture (subtitle) streams to display. This will hopefully force your player to display the stream you wish just like the original. I believe that this applies to Kill Bill 1 and some other titles.
     
  6. StanH1000

    StanH1000 Regular member

    Joined:
    May 19, 2004
    Messages:
    718
    Likes Received:
    0
    Trophy Points:
    26
    I had enable default streams checked but when Shrink uses the re-author mode on some movies you still have to deliberately select to turn on the subtitle tract (at least there will only be one).
    Last Samauri is a similar but diferent situation, in that the part time subtitles are part of the main title. The only selectable subtitle tract is the one for the whole film and need not be part of the burn.
    The Kill Bills differ in that there are originally two English subtitle tracts. Enabling the forced stream does not work if these titles are re-authored.
    After writing the Movie name on your burned disk, just add "Enable Subtitles" as a reminder.
     
  7. castun

    castun Member

    Joined:
    Jul 29, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    With Band of Brothers I just did a regular compression burn using DVD Shrink. If I didn't remove the forced French subtitles they would come up with any text (such as the time and date screens) even though they do not with the original disk.
     
  8. ngoti8tor

    ngoti8tor Member

    Joined:
    Dec 15, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    I found the way that I had to do it was as Stan mentioned: Using DVD Shrink, select the smaller English subtitle along with the main movie title, then compress and then burn (label DVD with movie name along with a note to "enable subtitle". When ready to play movie in a stand-alone player, enable the subtitle with the remote control and everything plays fine.

    I'd just like to add that I've been using Princo 4X general use DVDs and I've only had 2 coasters out of 180 DVDs, and I think it was because of a small scratch on each DVD. Not bad for $33CAN per 50 DVDs.

    Thanks to everyone that responded to my problem.
     

Share This Page