1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

External Hard Drive will not connect to computer thru usb (Solved)

Discussion in 'Windows - General discussion' started by Jman6785, Nov 30, 2008.

  1. Jman6785

    Jman6785 Member

    Joined:
    Jun 23, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Hi guys & gals,

    Im here because i have a frustrating issue that i need help with. I have been trying to figure this out all today (saturday) looking through lots of forums and related issues on google as well as the search forum here. I have tired countless fixes, but nothing has resolved my problem.

    On black Friday i purchased an external hard drive. The package says it is just plug n play but this is not the case. I have updated all drivers for my mother board and updated windows to SP3 with no luck.

    The drive is powered by USB 2.0 and the LED lights up when connected.

    When I open device manager it shows a yellow question mark for the device, i believe which means it needs a driver. However device manager shows the device under OTHER DEVICES => USB DEVICE.

    Here is a link to the picture of my device manager:
    http://img528.imageshack.us/my.php?image=62189035ze9.jpg
    (let me know if this link doesn't work, sometimes you have to copy & paste the link a second time for imageshack to show the image)

    I am not sure if you need computer information so here it is:

    ASUS M2N-SLI deluxe mobo
    AMD x2 5400+
    4GB ram


    Windows XP Home Ed. (updated to SP3)

    The external drive that im trying to get windows to recognize is:

    TOSHIBA 250gb USB 2.0 Portable External Hard Drive (Model: HDDR250E03X)


    I would like to also add that i cannot find a driver for the Toshiba drive online anywhere. I dont know if a driver is needed for the External drive or for the computer.

    Also, the drive does work on my other windows PC. The external drive is in working order.

    Thank you in advance for helping me solve this issue. From what i have searched, it seems many people have this problem with various external hard drives. Hopefully this will help other too.

    Let me know if you need any additional information.

    Thank you,
    Jason.
  2. AfterDawn

    AfterDawn Advertisement

  3. gollan

    gollan Member

    Joined:
    Nov 28, 2008
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    16
    You do not need any drivers at all for this product accroding to toshibia's FAQ's. you simply plug it in and it works, however, here is another statement from the FAQ

    I would reccomend if you have not already tried, plugging it into a different USB port, and see if it maybe s a power failure.

    http://www.storage.toshiba.eu/index.php?id=76&pid=237#

    Gollan
    Last edited: Nov 30, 2008
  4. Jman6785

    Jman6785 Member

    Joined:
    Jun 23, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Ok, im going to try to pick up a "y-shaped USB cable".

    i have tried every USB slot on my computer. it on shows in device manager on the front 2 USB ports. However, then LED on the external hard drive lights up on every USB port.

    I do have USB 2.0
    (Standard Enhanced PCI to USB Host Controller)

    Would device manager show the drive as a unknown device with a yellow question mark, even if it is not fully powered?
  5. gollan

    gollan Member

    Joined:
    Nov 28, 2008
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    16
    It Would proberly show it with an exclaimation mark yes...Have a look in ther a report back


    Gollan
  6. Jman6785

    Jman6785 Member

    Joined:
    Jun 23, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    ok guys. i went out today and bought a cheep 7 port USB hub. I made sure to get a hub that has a AV outlet for it to give more power.

    IT WORKED!

    so to all wondering, try out a AC powered USB hub and it should fire up.


    Thanks you everybody who help out. I appreciate it lots.

    have a good night!!
  7. gollan

    gollan Member

    Joined:
    Nov 28, 2008
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    16
    Glad It worked....It was all on there website. :)
  8. Jman6785

    Jman6785 Member

    Joined:
    Jun 23, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    figures. then one place i didn't think to look. i was thinking it was more of a windows problem.

    ha thanks guys.

Share This Page