1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fast and the Furious

Discussion in 'Sony Handhelds' started by hack01, May 10, 2007.

  1. hack01

    hack01 Regular member

    Joined:
    Feb 17, 2006
    Messages:
    568
    Likes Received:
    0
    Trophy Points:
    26
    I have got several downloads of this game and have unable to play it. When I run it it takes me back to the main screen and when I try to click on the UMD it says I need to upgrade to a 3.11 Does anyone know how to fix this?
     
  2. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    What Firmware do you have?
     
  3. lanxlan2

    lanxlan2 Member

    Joined:
    Apr 22, 2007
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    16
    just upgrade to 3.40oea
     
  4. hack01

    hack01 Regular member

    Joined:
    Feb 17, 2006
    Messages:
    568
    Likes Received:
    0
    Trophy Points:
    26
    I have a 1.50version and I run Devhook
     
  5. hack01

    hack01 Regular member

    Joined:
    Feb 17, 2006
    Messages:
    568
    Likes Received:
    0
    Trophy Points:
    26
    The game is an ISO if I upgrade me PSP, I would have to find out how to downgrade it back to 1.50 to play my other 100+ games that I have.
     

Share This Page