1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"File format is invalid" problems with VirtualDub

Discussion in 'Video - Software discussion' started by videophyt, Sep 30, 2002.

  1. videophyt

    videophyt Member

    Joined:
    Sep 30, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    when I capture a video file using VirtualDub (latest version 1.4.10), and then "Save as AVI" using either "Full Processing Mode" or "Direct Stream Copy" mode, the resulting AVI file generates a "File Format is Invalid" error in Windows Media Player when you seek with the slider. Once I get past this, I can acutally start editing in Vdub!!
     
  2. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    Did you use any video codecs or audio compression making this avi file?
     
  3. videophyt

    videophyt Member

    Joined:
    Sep 30, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Negative. Just straight capture from an S-VHS source with audio/video syncronization enabled. The captured file can be viewed/scanned no problem, but once you "save as AVI" with no filters no nothing, its hosed. I may try saving with a null filter just to see if it makes a difference . . .
     
  4. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    God computers can be touchy can't they!!! Even if VirtualDub won't open your file, try using TMPGEnc or Panasonic Mpeg-1 Encoder, they never seem to have too much trouble with avi files!
     
  5. videophyt

    videophyt Member

    Joined:
    Sep 30, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    TMPGenc will not properly encode the file after it has been "saved to AVI" by Vdub and then fails to play properly in the Windows Media Player (although Vdub can play it and seek in it just fine). The audio drops out. The "slider" test on the Windows Media Player is a pretty good barometer for not being able to encode with TMPGenc.
     
  6. Dela

    Dela Administrator Staff Member

    Joined:
    Aug 25, 2002
    Messages:
    8,949
    Likes Received:
    1
    Trophy Points:
    118
    If you captured the avi, what file size is it???
     
  7. Jake

    Jake Active member

    Joined:
    Apr 19, 2002
    Messages:
    2,550
    Likes Received:
    0
    Trophy Points:
    66
    Can you capture any other source than S-VHS? And you make .avi temporary file, why? Use some program what make .mpg file directly..
     
  8. VCDjunkie

    VCDjunkie Moderator Staff Member

    Joined:
    Sep 11, 2002
    Messages:
    512
    Likes Received:
    0
    Trophy Points:
    26
    try converting audio in virtual dub before putting it through tmpgenc.

    audio>full processing mode>> audio>conversion>44100 high quality 16bit stereo.. now either save wav to seperate the video and audio, or save avi and work with it as one piece.

    you can also save the video seperate from the audio by clicking audio>no audio then click video>direct stream copy, then save avi.

    may also want to change tmpgenc setting for the codec reader settings in under Option->Environmental settings->VFAPI plug-in and right click on the DirectShow Multimedia File Reader and increase the priority to 1 or 2 and try open the video.

    best of luck
     

Share This Page