1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fliptop installation vibrates when DVD spins up

Discussion in 'PS2' started by marthugh, Jul 11, 2003.

  1. marthugh

    marthugh Guest

    I have installed a fliptop to my PS2. However when the DVD spins up it vibrates and has trouble reading the disk unless I apply some pressure to the fliptop.

    The white hub appears to be fitted correctly (silver side facing up) and the fliptop lid is fitted squarely to the case.

    Any ideas what is wrong and what I can do to solve this. Running with an encyclopedia on top of the case is not an attractive long term option :)

    Many thanks in advance,
    Mart
     
  2. Wulfie66

    Wulfie66 Regular member

    Joined:
    May 25, 2003
    Messages:
    506
    Likes Received:
    0
    Trophy Points:
    26
    There is actually a magnet in that little white piece that holds the fliptop lid down. I suggest you check and make double sure that you got that white piece in properly.
     
  3. marthugh

    marthugh Guest

    Thanks. I believe I have. If I fit it with the silver side (magnet visible) pointing down towards the DVD the white hub cannot spin in the lid - so I am assuming the magnet-visible side must point up. Is this right?

    Thanks
     
  4. Wulfie66

    Wulfie66 Regular member

    Joined:
    May 25, 2003
    Messages:
    506
    Likes Received:
    0
    Trophy Points:
    26
    Yes, the actualy 'visible' part of the magnet should be pointing up towards the cover. I just checked mine to make sure. Also make sure that when your placing a dvd/cd in with the fliptop that it spins freely. I've had a few that will catch on the left side of the 'tray'.
     
  5. marthugh

    marthugh Guest

    Yeah, I had that to start with too. Things improved slightly, but I still have this really bad vibration and trouble reading without applying pressure. If I take the white hub out of the lid and place it on the DVD, and run with the lid up there are no problems - except that I don'treally want to leave the lid up.
     
  6. Wulfie66

    Wulfie66 Regular member

    Joined:
    May 25, 2003
    Messages:
    506
    Likes Received:
    0
    Trophy Points:
    26
    to me it sounds like your lid is catching on something (not closing all the way). Make sure that there isn't anything in there that the lid might be catching on.
     
  7. Hanedrick

    Hanedrick Regular member

    Joined:
    Apr 14, 2003
    Messages:
    845
    Likes Received:
    0
    Trophy Points:
    26
    I do what you do. I just took the white hub out and I manually put it on cause I was having the same problem as you. In order to shut the lid all the way just remove those black pegs that were supposed to hold the white hub. Works fine with me.
     
  8. marthugh

    marthugh Guest

    finally sorted this out. I removed all the screws and refitted the flip top. I did not do anything different to what I did originally, but it seems to be better seated and the problem has gone away.

    Thanks a lot for your responses.
     

Share This Page