1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forgive the downgrading noob.

Discussion in 'Sony PSP - Mod and firmware discussion' started by That__Guy, Apr 21, 2007.

  1. That__Guy

    That__Guy Member

    Joined:
    Apr 20, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    I have at my side, an IC-1003 Psp...
    With a 2.81 firmware?
    It's difficult for me going through all of these threads finding y exact situation, because they all vary a tad.

    I'm not sure if this is in the right forum, so if it's in the wrong one, tell me and i'll relocate =)

    Trying to get games to play on my 128 Stick.
    used to have a psp, got rid of it, now i'm back to one again ha ha.
    Just in case this happens again, I want to be ready to play my games again!!!

    Have got my collection up to Midnight club 3, and GTA VCS.
    So, if I back these up, and go to play it again, mind giving me a thumbs up if it upgrades my possible downgrade to 1.5?

    Cheers all, and hopefully you can help =)
     
  2. ggbarnum

    ggbarnum Regular member

    Joined:
    Apr 14, 2006
    Messages:
    1,432
    Likes Received:
    0
    Trophy Points:
    46
    Firstly, please only use thread titles that comply with forum rules.

    Secondly, what the hell are you on about ?

    Is this even english ?
     
  3. That__Guy

    That__Guy Member

    Joined:
    Apr 20, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    Sorry...
    I was asking if while running a 1.5 firmware (?), I loaded a game that updates the firmware, would it update?

    Sorry
     
  4. Frog1

    Frog1 Regular member

    Joined:
    Apr 19, 2007
    Messages:
    130
    Likes Received:
    0
    Trophy Points:
    26
    i would like to help u man but i couldnt understand the question really it might be just me.
     
  5. Frog1

    Frog1 Regular member

    Joined:
    Apr 19, 2007
    Messages:
    130
    Likes Received:
    0
    Trophy Points:
    26
    no it will have a pull down under the games menu that asks u to update but you dont have to. some of the later games require later firmwares to run them though. to get around this just update to a more recent custom firmware 3.03oe-c has worked for all games except star wars deadly alliance up to this piont.
     
  6. ggbarnum

    ggbarnum Regular member

    Joined:
    Apr 14, 2006
    Messages:
    1,432
    Likes Received:
    0
    Trophy Points:
    46
    ok, a game that requires fw higher than 1.5 will not run from UMD unless you upgrade.

    But if you are on 1.5, you should just upgrade to custom firmware which will solve your problems and allow you play all games and homebrew.

    There are lots of guides about doing this.
     
  7. That__Guy

    That__Guy Member

    Joined:
    Apr 20, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    Running: 2.81
    Psp: IC-1003

    Wants to eventuate with 1.5 firmware.

    Hopefully that helps?

    I only just found out you can do this stuff to your Psp yesterday, so apologies.
     
  8. Frog1

    Frog1 Regular member

    Joined:
    Apr 19, 2007
    Messages:
    130
    Likes Received:
    0
    Trophy Points:
    26
    you need to downgrade to firmware 1.5 first search on how to do that. and then upgrade to one of the latest firmwares. read around some people like some firmwares over others i like firmware 3.03oe-c. but ultimately the chioce is yours.

    *edit* by the way if you only found out you can do this to your psp yesterday you have got a ton of reading to do. spend some time researching it will only benifit you.
     
    Last edited: Apr 22, 2007

Share This Page