1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FSCTL_LOCK_VOLUME ERROR, HELP?

Discussion in 'Convert DVD to another format' started by SPARKY01, Dec 6, 2004.

  1. SPARKY01

    SPARKY01 Member

    Joined:
    Dec 3, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    11
    I'm using decrypter to burn with and I get keep getting and error when I first start to burn...

    Device Control (FSCTL_Lock_Volume) Failed!
    Device [1:00] HP DVD Writer 300N 3.11 (E:)(ATA)
    Unable To Lock Volume For Exclusive Access.
    Reason: Access is Denied.

    Abort Retry Ignore

    I choose ignore and it burns the disc without apparent problems as it plays on both computer and player.
    Anyone got some Idea how to fix this?
     
  2. AfterDawn

    AfterDawn Advertisement

  3. Nephilim

    Nephilim Moderator Staff Member

    Joined:
    Feb 13, 2003
    Messages:
    14,942
    Likes Received:
    0
    Trophy Points:
    116
    This is most commonly caused by packet writing apps such as InCD, DLA or Drag to Disc. Part of the way they work is to keep constant access to the drive so when another burning app needs to gain exclusive access to the drive it can't and the write process will be aborted. If you have any packet writing apps, uninstall them and see if that clears up your problem.

    If that doesn't work it could also be Windows built in IMAPI burning service which also likes to keep access to the drive. It's a useless app to begin with and even more so when you have dedicated burning software installed.

    IMAPI can be disabled by following these steps:

    Start >
    Control Panel >
    Administrative Tools >
    Services >

    Now scroll down to IMAPI CD-Burning COM Service and double click it.

    In the Properties window under the General tab look for the Startup Type drop down menu and select Disabled. Click OK and you're good to go.



    If, and only if, the steps above don't work you can set Decrypter to where it doesn't need to lock the drive by doing the following:

    Tools > Settings > ISO Write Mode > then uncheck "Lock Volume - Exclusive Access".

    By using this method you're possibly leaving yourself open to failed burns if another app interrupts the burn process.
     

Share This Page