1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Games not working after downgrading

Discussion in 'Sony PSP - Homebrew software' started by Sion88, May 22, 2007.

  1. Sion88

    Sion88 Member

    Joined:
    May 17, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    I recently downgraded my IC1003 PSP to 1.5 so that I could play roms but found out that now I can't play UMD games. The emulators I have are RIN GB/GBC Emulator and DGEN for PSP Ver 1.00. The UMD game I have is DBZ Shin Boudaki and it says I need to update to 2.60 to play it. So my question is, is there a system version that will let me play my emulators while still being able to play PSP games, without turning this IC1003 into a brick? (I guess IC1003 brick when downgrading and maybe upgrading?)
     
  2. ace916

    ace916 Member

    Joined:
    Mar 28, 2007
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    16
    ull need to upgrade to 3.03 oe or higher my recommendation is 3.03 oec
    make sure it oe and not regular firmware. heres a link

    http://downgrader.lan.st/

    u did the hard part by downgrading upgrading to custom firmware is not that hard just follw the directions

    check out these emulators for psp just download the ones u want recomend
    gpsp gba emulator

    snes9txl snes emulator
     
  3. Sion88

    Sion88 Member

    Joined:
    May 17, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Thanks a lot. Oh and I tried to use gpsp but I need the GBA bios image. After hours of searching I gave up on it. I'd like to get a GBA emulator though and I heard gpsp was the best, just can't get it to work.
     
  4. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    google gba_bios.bin
     

Share This Page