1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

God help me! PCI Cont. card for ATA Serial won't see my WD HDD, did b/f XP reformat

Discussion in 'PC hardware help' started by bigrush, Apr 23, 2005.

  1. bigrush

    bigrush Member

    Joined:
    Jul 24, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I have a 250 GB Western Digital WD2500 hardrive. It is serial ATA connected to a PCI Controller card (Adaptec 1205SA). I am using it as a second slave drive.

    It worked fine before I reformatted XP. Now when I go to device mgr. it has a yellow question mark next to it. I have tried to update, install, rollback, and disable drivers. Nothing works. It says drivers for this device were not installed "Code 28". As far as I know hardrives don't require drivers, do they??? I updated the driver to my PCI Controller card, but it still doesn't work. I have resetaed the controller and the serial ATA cable on both ends, and of course rebooted many, many times. I also think I have all XP updates as well as SP2 installed. It just won't recognize this HDD like it did before as a HDD.

    The latest attempt I made was to buy a brand new ATA controller - exact same kind (with serial cable of course) and install that. Still no luck.

    Please any suggestions/thoughts would be SO greatly appreciated. I have my entire music library on this HDD. Please help me with ideas. Thanks in advance. Oh ya, this is a kick ass site by the way!
     
  2. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,011
    Likes Received:
    78
    Trophy Points:
    128
    how about uninstalling the card than restart windows to let it load it's drivers
     
  3. bigrush

    bigrush Member

    Joined:
    Jul 24, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for the suggestion, but that is also something I tried..
     
  4. baabaa

    baabaa Active member

    Joined:
    Jan 7, 2003
    Messages:
    2,217
    Likes Received:
    0
    Trophy Points:
    66
    It worked before you reformatted XP, have you missed anything during the reinstall, like motherboard drivers?
    Basically how did you install it originally, sometimes if you can work backwards you may discover if you left something out or not.

    Have you tried the card in an alternative slot?

    Code 28 is basically reinstall drivers, drivers not uptodate, no drivers to install etc, have you been to the website for the PCI card and checked to see if there are any FAQ's/driver updates etc?
     
  5. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,011
    Likes Received:
    78
    Trophy Points:
    128
    did you load the sata device drive when installing xp??
     
  6. baabaa

    baabaa Active member

    Joined:
    Jan 7, 2003
    Messages:
    2,217
    Likes Received:
    0
    Trophy Points:
    66
    ah, yes............you may need the third party drivers that should be included in your motherboard disc..........good point ddp (as usual)
     
  7. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,011
    Likes Received:
    78
    Trophy Points:
    128
    & i don't have a pointed head either maybe ears but not the head!!
     
  8. baabaa

    baabaa Active member

    Joined:
    Jan 7, 2003
    Messages:
    2,217
    Likes Received:
    0
    Trophy Points:
    66
    LMAO.......cheers Mr Spock...........
     

Share This Page