1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GTA Unpatched

Discussion in 'Sony PSP - Mod and firmware discussion' started by chkm8t, May 25, 2007.

  1. chkm8t

    chkm8t Member

    Joined:
    Dec 5, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    Do I need GTA unpatched to play all downloaded games or just for GTA?
     
  2. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    You need Gta(liberty city) to downgrade from 3.03 to a lower firmware to play downloaded games :)
     
  3. Oraseth

    Oraseth Regular member

    Joined:
    May 21, 2007
    Messages:
    183
    Likes Received:
    0
    Trophy Points:
    26
    Depends also what firmware you have on your PSP, if you have anything from 1.50 to 2.80, you only need the appropriate downgrader to get to 1.50. (and can upgrade to a custom firmware from there)

    If you have a 2.81 to 3.03 you need GTA:LC early edition to downgrade (2.0 version)

    3.10 to 3.40 firmware currently have no option available that allows downgrading/installing custom firmware.
     

Share This Page