1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

have psp 2.60 and trying to play iso;s

Discussion in 'Sony PSP - Mod and firmware discussion' started by clowone, Jul 5, 2007.

  1. clowone

    clowone Member

    Joined:
    Jul 5, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    hi guys,
    new use here.
    just got my psp and have been reading many post and forums on how to downgrade/upgrade to get the best out of my psp,

    i must say that by now i am confused, some sites tell you one thing while others tell you something else.

    I currently have a 2.60 and have not done anything to it..

    my main goal is to just play isos on my psp, can you please tell me what i need to do? i have read i have to upgrade first and then downgrade and i am cofuesd.

    i have read the psp sticky and still not certain about what to do, i apologize if this has been asked before,
    i have a ic1003 , version 2.60,

    thank you..
     
  2. smlvfx

    smlvfx Regular member

    Joined:
    Dec 9, 2006
    Messages:
    1,358
    Likes Received:
    0
    Trophy Points:
    46
  3. clowone

    clowone Member

    Joined:
    Jul 5, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    hi , thanks for a great start..
    i got stuck at the point were i am trying to run the 1.5 installer,
    i keep getting an error message that says
    the game could not be started
    80020148

    and press back..
    i did get the blue screen when i ran the hen file..

    any help please?
    tanks
     

Share This Page