1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Have ver. 4 ps2 and just bought ver 9 ps2. will swap magic cd 3.2 work on ver. 9?

Discussion in 'PS2 - DVD backup discussion' started by jay33, Aug 16, 2004.

  1. jay33

    jay33 Regular member

    Joined:
    Jun 29, 2003
    Messages:
    428
    Likes Received:
    0
    Trophy Points:
    26
    I've already tried my swap magic cd 2.0 on my new ver. 9 ps2 and it won't even recognize the disc. I know the new 3.0 (3.2) Swap Magic cd is supposed to work with ver9 and up, but I have read that many people have problems with it not working.

    Also, for DVD games that require the double switch with Swap Magic cd, I assume that if the SM cd won't work to boot a cd backup, then it won't work when you try to use it initially and coupled with the cd loader. For DVD games that require the cd loader, can you use the DVD loader and not have to use the Swap Magic CD at all??
     
    Last edited: Aug 16, 2004
  2. bboy_flex

    bboy_flex Regular member

    Joined:
    Jun 24, 2004
    Messages:
    231
    Likes Received:
    0
    Trophy Points:
    26
    Swap magic 3.2 should be able to work on version 9 + 10 ps2s. When u buy it just remember to buy usa build for ntsc ps2s and pal for pal ps2s. For dvd backups that require the double switch u can use dvd loader. That way u will not need to use the swap magic cd but u will still need to use the swap magic dvd.
     

Share This Page