1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Having a problem playing video files in Media Player Classic

Discussion in 'Video - Software discussion' started by Boco77, Feb 21, 2007.

  1. Boco77

    Boco77 Member

    Joined:
    Feb 18, 2007
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    16
    Using version 6.4.9.0 of MPC but it doesnt seem to play all video files for some reason. Most files play in it but some xvid's dont, and they play fine in WMP.

    I get this error message when trying to play in MPC.

    Media player could not render some of the pins in the graph. You may not have the needed codecs or filters installed on the system.

    Media Type 0:
    --------------------------
    Video: XVID 960x528 23.98fps 1895Kbps

    AM_MEDIA_TYPE:
    majortype: MEDIATYPE_Video {73646976-0000-0010-8000-00AA00389B71}
    subtype: Unknown GUID Name {44495658-0000-0010-8000-00AA00389B71}
    formattype: FORMAT_VideoInfo {05589F80-C356-11CE-BF01-00AA0055595A}
    bFixedSizeSamples: 1
    bTemporalCompression: 0
    lSampleSize: 338397
    cbFormat: 88

    VIDEOINFOHEADER:
    rcSource: (0,0)-(0,0)
    rcTarget: (0,0)-(0,0)
    dwBitRate: 1895929
    dwBitErrorRate: 0
    AvgTimePerFrame: 417083

    BITMAPINFOHEADER:
    biSize: 40
    biWidth: 960
    biHeight: 528
    biPlanes: 1
    biBitCount: 24
    biCompression: XVID
    biSizeImage: 1520640
    biXPelsPerMeter: 0
    biYPelsPerMeter: 0
    biYPelsPerMeter: 0
    biClrUsed: 0
    biClrImportant: 0

    pbFormat:
    0000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
    0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
    0020: f9 ed 1c 00 00 00 00 00 3b 5d 06 00 00 00 00 00 ùí......;]......
    0030: 28 00 00 00 c0 03 00 00 10 02 00 00 01 00 18 00 (...À...........
    0040: 58 56 49 44 00 34 17 00 00 00 00 00 00 00 00 00 XVID.4..........
    0050: 00 00 00 00 00 00 00 00 ........
     
  2. rdmercer1

    rdmercer1 Active member

    Joined:
    Nov 11, 2004
    Messages:
    2,435
    Likes Received:
    0
    Trophy Points:
    66
    you could download the mega codec pack
     
  3. Rikoshay

    Rikoshay Regular member

    Joined:
    Apr 13, 2004
    Messages:
    307
    Likes Received:
    0
    Trophy Points:
    26
    Open MPC, go to Options>Internal Filters, uncheck AVI in that field.
     

Share This Page