1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Having video/audio sync issues

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by OzzmosisD, Dec 15, 2003.

  1. OzzmosisD

    OzzmosisD Member

    Joined:
    Dec 15, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I am converting some Divx movies to VCD format and I am using VirtualDubMod, TMPEnc and VCDEasy to do so. However, when I split the avi with VirtualDubMod the sound is not in sync. What I did was I split the avi, then ripped the audio from each half and when I look at the length of the audio file versus the length of the video, each one was off by about 30 seconds. I tried using goldwave to stretch the audio file, but it was still off.

    I also get this error message when I open up the avi in virtualdubmod that says "VirtualDub has detected an improper VBR audio encoding in the source avi file (audio stream 1). The current preference is to rewrite the audio header with standard CBR values durring processing for better compatibility. This may introduce up to 41897 ms of skew from the video stream. If this is unacceptable decompress the entire audio stream to an uncompressed wav file and recompress with a constant bitrate encoder (bitrate: 150.4+ 15.1kbps)." Could this be causing my problem? If so, how do I decompress the audio stream and recompress like it says? Will virtualdub do this for me or will I need another program?

    Thanks for any help, this is becoming very frustating.
     
  2. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Yes..Your Problem is that the audio is VBR Mp3 and it will cause sync Problems ....What you have to do it Uncompress the audio then you can edit the File into Parts....So Load your AVI into Virtual Dub ,Then under "Video" set it to "Direct Stream Copy" then usder the "Audio" set it to "Full Proscessing Mode" then go to "Audio to "Compression" and make sure it is set to "None" or "Uncompressed" and then go to "File" to "Save AVI" and save the AVI file...Now use this File to Cut in Half in Virtual Dub or you Can just encode this File in tmpgenc and use Tmpgenc"s "Source Range" to encode the File in Parts, Or you can encode it as One Big Mpeg file and use Tmpgenc"s "merge & Cut" to Cut the File in Half.....Cheers
     
  3. manstim

    manstim Member

    Joined:
    Dec 18, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Hello just wanna enquiry. I'm using a virtual Dub to capture from my VHS. No Sync problem anymore reading the setting from this forum. During "capture" the video/audio is Ok, when I do a play back, the video is OK but No Audio (although the vol.level is to the max). This puzzle me, all setting is according to specs. Any clue,suggestion or ideas, would be a great help.

    Anyway I'm using DVC 80 for my video & Creative SoundBlaster Live 5.5 (Line-In) for my Audio. Thx u.
     
  4. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Have you made sure that you have the "Line in" selected in windows for Recording??? to do this go to the Volum Icon in your Task Bar and Right click on it and "Open Volume Controll" andf Make sure that "Line in" isn"t Muted, then go to "options" to "Properties" then click "Recording" and select "Line in" From the List and Click "OK" then under "Line In" Click "Select" and set the Recordeing Volume and then close the Windows and then you should be able to record from the Line in Jack...Cheers

    PS: the DVC 80 Is the Worst Capture device on the Market and you can get something that will Capture in 4 Times the Resolution with Much Better Quality For Probably 1/3 the Price and One that isn"t USB but PCI..I have Seen Full resolution PCI capture Cards On E-bay for as Low as $15 US Plus Shipping....._X_X_X_X_X_[small]It"s better to be Pissed Off than Pissed On!!![/small]
     
    Last edited: Dec 18, 2003
  5. manstim

    manstim Member

    Joined:
    Dec 18, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Hi Minion, Thx for the advice, but thats not it. Actually i've found out why. Since Virtual dub dun have its own "personalise" setting for Video & Audio. I run a 3rd party Video editing software & allocate the Audio setting to "Line-in" & closed the program. VIOALA!! Doned. Thx U.
     

Share This Page