1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HD MKV skipping *SOLVED

Discussion in 'Blu-ray players' started by Freekman, Dec 27, 2008.

  1. Freekman

    Freekman Regular member

    Joined:
    Mar 7, 2007
    Messages:
    216
    Likes Received:
    0
    Trophy Points:
    26
    so i couldn't seem to find this topic anywhere before, but i have a decent rig and for some reason the 1920X1080 mkv is being really jumpy also when I try to play the file in MEdia player classic it crops down to 960 x 540
    here is my system
    Sapphire 4870
    3gb DDR2 ram
    320gb HD
    4600 X2 @ 2.5 ghz
    VLC player
    K lite codec
    Video information
    Format : Matroska
    Writing library : x264
    Interlacement : Progressive
    Codec : AVC
    Codec : AC3

    please help thanks

    ****************************
    this was my solution just found it

    Basically the requirements to getting H264 acceleration working are:
    1. A video card that supports H264 acceleration (duh), which is either the Nvidia 8xxx or 9xxx series, or ATI Radeon HD series.
    2. Media Player Classic Home Cinema (MPC-HC) from http://tibrium.neuf.fr/index.html
    3. An H264 file that's encoded in a way that works :p. (As I understand it, there are some limitations in what the hardware is able to decode, since it was really meant for Blu-ray/HD-DVD.)

    After you extract MPC-HC somewhere (I just overwrote the version of MPC that was installed by the CCCP, you need to change several things in Options. First, under "Internal filters", then make sure "H264/AVC (DXVA)" is checked. Under Playback -> Output, you need to have EVR Custom pres. selected. Finally, under Playback, you'll want to check "Auto-load subtitles".

    Finally, assuming you have CCCP installed, you need to go to CCCP in your programs menu, then Filters, then VSFilter configuration. In the "General" tab, you need to tell it not to load. I don't quite understand it, but apparently VSFilter puts the subtitles on the screen after the renderer, which breaks hardware acceleration. However, MPC-HC seems to handle the subtitles fine, from what I can tell.

    To check if it's working, after loading a video, right click on the video, go to "Filters", then "MPC Video Decoder". Under DXVA, it will tell you if it's being used or not.

    Note: If you're using an ATI 2600 or 2400 and dual monitors setup, the drivers have a bug that breaks hardware acceleration. If this is your setup, you'll have to download the http://exdeus.home.comcast.net/~exdeus/ati-hd2x00/ and make sure you enable "VForceUVDH264".

    I'm using Vista x64 and a ATI HD2600xt; I'm using the 32-bit version of MPC-HC. With hardware acceleration, most of the files I play back average about 5% or so CPU utilization, peaking at maybe 10% or so. In contrast, without acceleration, my CPU utilization averages around 25% and peaks at 50%, so it makes a big difference, though my system can play the files fine without acceleration.

    Although hardware acceleration is pretty impressive, it doesn't work with all H264 encodes. In fact, for this season, it's about a 50/50 chance of whether a given release will work; for example, RD works, but Kurenai doesn't. So it's not as handy as it could be, though groups are definitely getting better at encoding stuff that works.

    credit does not go to me but i thought if anyone else was having my issues you could use this info
    Last edited: Dec 27, 2008
  2. AfterDawn

    AfterDawn Advertisement

Share This Page