1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Headset Sound Issue

Discussion in 'PC hardware help' started by Kensukete, Feb 12, 2013.

  1. Kensukete

    Kensukete Member

    Joined:
    Jul 30, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    I have a problem where the audio the people hear from my headset is squealing. Originally I thought it was the headset itself, but I just purchased a newer one and that didn't work either, so now I'm thinking its the sound card. Any ideas?

    Right now I'm using my motherboard's sound, and I started using a TekRepublic TH Pro gaming headset.
    Last edited: Feb 12, 2013
  2. AfterDawn

    AfterDawn Advertisement

  3. Kensukete

    Kensukete Member

    Joined:
    Jul 30, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    Never mind, I fixed the issue. Please close this topic.
  4. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    37,700
    Likes Received:
    5
    Trophy Points:
    98
    how did you fix it so that others may learn from that problem?
  5. Kensukete

    Kensukete Member

    Joined:
    Jul 30, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    With the new headset it came with software that allowed me to adjust the feedback with a new mixer. I was able to get the right settings.
  6. Kensukete

    Kensukete Member

    Joined:
    Jul 30, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    I actually have a newer issue that I wasn't expecting. A day after use I put my computer to sleep, now the computer doesn't even see the headset as headset anymore, but as an unknown USB device. I've tried uninstalling and rebooting and it won't get back to normal.
  7. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    37,700
    Likes Received:
    5
    Trophy Points:
    98
    try a system restore to before this started. was there a windows update recently installed?
  8. Kensukete

    Kensukete Member

    Joined:
    Jul 30, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    11
    There was, but this happened before I did the update. I figured the update would help, but that didn't work either.

Share This Page