1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP!!!BATTERY NOT WORKING!!!

Discussion in 'Sony Handhelds' started by DNTL, Oct 8, 2007.

  1. DNTL

    DNTL Member

    Joined:
    Sep 13, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    i am desperate! this happened out of nowhere!!!

    i dun know what the heck happened, but my psp won't power on using the battery.

    i turn on the psp using ac adapter, works fine for a few minutes, then tunrs off abrubtly. when I go to system settings->batter info.
    it says just "External" as thepower source. The other things are all blank. I also noticed that when i turn on the psp with the ac and battery inserted, the top where it says the time and date and usually the battery level, the battery meter turns on and off every 2-3 seconds in no particular pattern. My PSP isn't real a playstation PORTABLE anymore, because to turn it on I have to plug it and use ac the whole time.

    how can i fix this??? PLEASE HELP ME!!!


    NOTE: using 3.52 m33-4

    SOMEONE HELP ME!!!!!!!!!!!!!!!!!!!!!
     
  2. Rav3

    Rav3 Regular member

    Joined:
    Aug 11, 2007
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    This sounds like a hardware problem, have u dropped or knocked ur psp lately to have damaged the parts inside? If so, I recommend buying a new unit, unless u can be bothered to solder new parts onto the motherboard.
     
  3. aaargghh

    aaargghh Member

    Joined:
    Mar 8, 2007
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    16
    Have you opened the inside? If not, give sony a call, they should be able to replace the psp or battery, they did this with mine.
    Worse case they will offer to replace the motherboard for 60 quid
     
  4. Rav3

    Rav3 Regular member

    Joined:
    Aug 11, 2007
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    Yep, definitely a hardware problem it seems. U will need to get it replaced (preferably by sony). It's expensive, (60 quid is hmm..130 AUD?) but it's better than buying an entirely new unit for $280 AUD
     
  5. pets34me

    pets34me Regular member

    Joined:
    Jul 6, 2007
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    26
    the same thing is happening to me, but I think it is because i'm not using a charger made by sony. it's llike a universal one that won't charge it. My dog chewed up my offical charger. luckily i found my usb charger which works
     
  6. Rav3

    Rav3 Regular member

    Joined:
    Aug 11, 2007
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    Oh well at least ur dog did chew up your GENUINE 8GB MS PRO DUO! :(
     
  7. pets34me

    pets34me Regular member

    Joined:
    Jul 6, 2007
    Messages:
    243
    Likes Received:
    0
    Trophy Points:
    26
    that sux...
     
  8. Hacker06

    Hacker06 Guest

    just talked to him and hes very busy so he asked me to post this

    he tried what everyone above me said and it worked until 30 min later, and then it comletely turned off

    any adive

    and he has not droped it recently and has not opened it but has tryed to(took off one screw lost it , and left there) so it has no sticker

    how do i know this he is part of my team... team h6
     
    Last edited by a moderator: Oct 8, 2007
  9. Rav3

    Rav3 Regular member

    Joined:
    Aug 11, 2007
    Messages:
    227
    Likes Received:
    0
    Trophy Points:
    26
    U lost the screw near the PSP warranty sticker? Well, that's also where the power related hardware is so maybe that's why. Try finding a replacement screw or a screw from a less important place of the PSP (which there isn't really)
     
  10. Hacker06

    Hacker06 Guest

    ya it was near the warranty sticker. mabey thats the reason
     
  11. DNTL

    DNTL Member

    Joined:
    Sep 13, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Thanks Hacker06 for the post.

    Anyway, it still isn't working. TO make sure you guys know what i'm talking about, i will show you a video i took using a screen gif capture plugin. Just click "Video" to see a quick clip of it:

    Video

    You can see what is goin on if look at the top-right.You can see the battery meter turn on a and off.I guess my psp isn't detecting the battery for some reason... I did not do anything to the psp including moving anything while filming.

    Please continue to post sollutions to this problem!!!

    PS: If anyone has a psp they are willing to sell, bricked, used, whatever, please tell me!

    HELP!!!!!!
     

Share This Page