1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Downgrading my PSP

Discussion in 'Sony PSP - Mod and firmware discussion' started by Dacian, Apr 9, 2007.

  1. Dacian

    Dacian Member

    Joined:
    Mar 11, 2006
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    16
    I have a PSP with 2.81 FW with a TA-O82 motherboard. I know that 2.81 can't be downgraded but is it possible to upgrade to 3.03 and then downgrade that to 1.5 so that I can play Homebrew? Thanks for the help and I have looked with search but didn't find anything, that's why I started a new thread.
     
  2. ggbarnum

    ggbarnum Regular member

    Joined:
    Apr 14, 2006
    Messages:
    1,432
    Likes Received:
    0
    Trophy Points:
    46
    The fact that you specifically asked if you can upgrade to 3.03 then downgrade would indicate that you have already read that you can do this.

    So as the many many threads round here say, yes you can but you will nedd an original GTA:LCS UMD to do it.
     
  3. Dacian

    Dacian Member

    Joined:
    Mar 11, 2006
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    16
    Yep, I've read about PSP's being downgraded from 3.03, but my question really is "Can the TA-O82 PSPs be downgraded period?". Because I've read you can't download them at all. Even when looking at the mother thread thing it says it can be, but also shows that it can't be in the picture. Kind of confusing to me, but anyway, how do I get it down to 1.5 then with GTA:LCS? I saw a thread about doing it on here but does it work with my motherboard?
     
  4. ggbarnum

    ggbarnum Regular member

    Joined:
    Apr 14, 2006
    Messages:
    1,432
    Likes Received:
    0
    Trophy Points:
    46
    yep, the 3.03 downgrader will work with any mobo.
     
  5. Dacian

    Dacian Member

    Joined:
    Mar 11, 2006
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    16
    Alright, I have it upgraded to 3.03 now. So before I go out and rent LCS, I've read about 3.03 OE, so before I downgrade, can I upgrade from 3.03 to 3.03 OE? Or even better, 3.10 OE, or any higher Custom Firmwares.
     
    Last edited: Apr 9, 2007
  6. Dailen

    Dailen Member

    Joined:
    Feb 4, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    11
    You need firmware 1.5 (what you should get when you downgrade) to be able to flash (install) 3.03 OE-C. At firmware 1.5 you may also upgrade to 3.10 OE-A. As of right now, I prefer 3.03 OE-C and I am hoping Dark Alex http://www.dark-alex.org/ comes up with a 3.30 OE.

    P.S. If you upgraded to Sony's 3.30 instead of Sony's 3.03 you screwed yourself over for being able to get into any homebrew activity (aka being able to upgrade to any custom firmwares like 3.03 OE-C or to run any other homebrew). You will need to wait for a 3.30 downgrade which will not be out for a while if one even comes out.

    If everything's good, just make sure your GTA:LCS disc has the v2.0 update on it. Then everything should work.
     
    Last edited: Apr 9, 2007
  7. Dacian

    Dacian Member

    Joined:
    Mar 11, 2006
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    16
    Alrighty, thanks for the info!
     

Share This Page