1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

help!!! PS2 screen goes blank after modchip installed

Discussion in 'PS2 - Hardware boot discussion' started by yojimbo1, Sep 12, 2004.

  1. yojimbo1

    yojimbo1 Member

    Joined:
    Jul 31, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    11
    My unit is experiencing problems. Originally my PS2 modded console was working ok (my backups worked fine) after a "tune-up" (realignment and solder check). However, after a day or two, the screen went blank and I don't see anything on the screen at all; I can't seem to play anything, not even the originals games, or even movies.

    Help Please!!!
     
  2. nelswick

    nelswick Regular member

    Joined:
    Jul 24, 2004
    Messages:
    765
    Likes Received:
    0
    Trophy Points:
    26
    did you wear an anti-static wristband or something similar when you installed/tuned up your ps2?
     
  3. yojimbo1

    yojimbo1 Member

    Joined:
    Jul 31, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    11
    I don't know the answers to that, but I have a friend technician who installed the chip for me, tested it, and it worked fine for a while. I played my backups for a day or two, and then blank...

    All of my cables and connections are fine. Every once in a blue moon, the PS2 comes up but if I reboot it, it goes away and goes blank. Anyone?
     

Share This Page