1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help, PSP ISOs im a noob and i need expert help!

Discussion in 'Sony PSP - Mod and firmware discussion' started by Brad92, Jun 1, 2007.

  1. Brad92

    Brad92 Member

    Joined:
    Jun 1, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    11
    Hi i have isos of two of my psp games, MLB 07: The Show and GTA: Vice City Stories. I've been trying to work out how to make them playable on my PSP, I downloaded some software called Fastloader 0.7 and put that on my mem stik along with the iso (all in the right places). It says corrupt data btw i have 2.50 firmware does that change anything?
    thanks alot!
     
  2. haxer00

    haxer00 Guest

    all you have to do my frend is update to the latest psp firmware 3.50 , you can play homebrews and iso. tell me when you updated ok?
     
  3. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    Don't listen to him! upgrade to 3.5 will take away all you homebrew abilities!!!
    You can still downgrade to 1.5fw then upgrade to an OE firmware. No devhook or fastloader needed

    Here's a link for 2.5 downgrade:
    http://forums.afterdawn.com/thread_view.cfm/362944

    Edit: link added
     
    Last edited: Jun 1, 2007
  4. haxer00

    haxer00 Guest

    his lieing you will brick your psp which means your psp is dead, if you do listen to him, invite me to your psp's funeral
     
  5. Brad92

    Brad92 Member

    Joined:
    Jun 1, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    11
    i really appreciate your help guys but who's right?
     
  6. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    Don't listen to that noob. He's just mad that he can no longer do homebrew and is trying to make you homebrewless. There are tons of people waiting around for a downgrader for 3.11 and up. Why? Because there isn't one. They are stuck. But hey, don't believe either of us. Do a search, and think for yourself.
     

Share This Page