1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with Dashboard Update

Discussion in 'Xbox 360 - Modding & Hacking' started by Wilson_93, Dec 27, 2011.

  1. Wilson_93

    Wilson_93 Member

    Joined:
    Nov 13, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    I have a Phat with a lite-on. Last time I updated it was last year. Now I got MW3, and installed the update, which made me unable to play all my backups.
    I've been reading that my drive was flashed back to stock. Can I flash it normally with LT? I dont have any original key, but I have a probe.
    One more question. If I put LT 3.0, do I have to patch and reburn my games? My console is banned so I only play offline.
     
  2. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    You can extract the key from the drive using the probe, so you can flash it, no problem.

    LT+ 3.0 is the way to go. You do need to repatch and reburn any games protected by AP2.5, but (hopefully) you will never have to do that again in future.

    There's a bunch of FAQs/tutorials linked to in post 1 of this thread that should help you, including ones that cover everything you need to know about LT+ 3.0, patching games etc.: -

    http://forums.afterdawn.com/t.cfm/f-152/tutorial_faq_links-916280/
     
  3. Wilson_93

    Wilson_93 Member

    Joined:
    Nov 13, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    LT 3.0 wont let me play games like MW3? Cant I just update it to LT 2.something?
    Lets say that I cant get DVD DLs easily from where I am
     
  4. Wilson_93

    Wilson_93 Member

    Joined:
    Nov 13, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    And I just bought 2 backup games (MW3 and Saints Row 3). Do you think they will have the patch already?
     
  5. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    What changed the game was MS implementing a new anti-piracy protection called AP2.5. This affects a number of games, including MW3 and Saints Row 3.

    With LT+ 2.0, you had to make sure that your backup was patched with the correct AP2.5 data. MS updated the protection from time to time, so you would have to rip the backup, patch it with new AP2.5 data, then re-burn it. It was easy to get your console flagged by booting a backup that wasn't patched, or wasn't patched with the correct data.

    With LT+ 3.0, you still have to make sure that your backups are patched correctly when you initially burn them, but you will not have to re-patch and re-burn your games every time the protection is updated by MS as the AP2.5 data stored on the disc is capable of answering any challenge that MS currently use.

    In both cases, badly patched/unpatched backups will not boot and trying to boot one - either online or offline - will flag your machine.

    If your console is banned, you may be able to stay on LT+ 2.0 and play existing backups offline, as long as they are patched with the correct AP2.5 data. As you don't go online, the AP2.5 data will not need updating, but there will come a day when new games require you to update your dashboard in order to play them, which may also update the AP2.5 data and that'll cause you problems.

    Also, another problem is, if a game is patched for LT+ 2.0 it won't boot on LT+ 3.0 and vice versa.

    So, in short, the best thing to do is always use the most current "safe" methods. That'll cause you less hassle in the long term. Update your console to the latest dashboard version. Flash to LT+ 3.0. Make sure that any AP2.5 protected games you have are correctly patched for LT+ 3.0.
     
  6. Wilson_93

    Wilson_93 Member

    Joined:
    Nov 13, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    First of all, thank you very much for the replies.
    So if my MW3 and Saints Row are patched for LT 2.0 it wont work on LT 3.0? Not even if I use that Horizon method? I'm not worried abou being flaged as I'm already banned.
     
  7. funksoulb

    funksoulb Regular member

    Joined:
    Oct 4, 2008
    Messages:
    1,713
    Likes Received:
    0
    Trophy Points:
    46
    Yeah, before LT+ 3.0, the AP2.5 patches that were inside backups were based on the current DAE.bin file - a file that holds a table of all of the current challenges. LT+ 2.0 was designed to use the data patched in a backup to defeat the current AP2.5 challenge only.

    With LT+ 3.0, new topology data is stored inside the backup and that allows it to defeat any AP2.5 challenge, so DAE.bin is now irrelevant. This particular anti-piracy method has now been properly defeated.

    As such, your backups can either be patched for LT+ 2.0 or LT+ 3.0, not both. If your console is already banned, the worst that will happen is that you'll try and boot a backup, it will fail the AP2.5 challenge, and it won't boot. Your console will also be flagged for failing an AP2.5 challenge, but it's already banned anyway.

    In the long term, you are still better off going with the latest dashboard, LT+ 3.0, and backups patched for LT+ 3.0 though. If you "obtain" backups in the future, they will probably be patched for use with LT+ 3.0. The next version of abgx360 will automatically patch games for use with LT+ 3.0. If you're sticking with a flashed console as a means of playing backups, rather than using an xk3y or other mod, then that is definitely the way to go. It's better to get up to date with things now, rather than be forced to update to LT+ 3.0 some time in the future when you may have a stack of backups that will all need re-patching and re-burning.
     
    Last edited: Dec 28, 2011
  8. Wilson_93

    Wilson_93 Member

    Joined:
    Nov 13, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    Alright. Tomorrow morning I'll flash it with LT + 3.0, then I'll tell you if it's working perfectly.
    Thanks a lot man, really helpful! I really apreciate it.
     
  9. Wilson_93

    Wilson_93 Member

    Joined:
    Nov 13, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    But can't I play MW3 patched for LT 2.0 in LT 3.0 with that Horizon Title Update?
     
  10. Wilson_93

    Wilson_93 Member

    Joined:
    Nov 13, 2007
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    Well, I guess I'll have to do this some other time. Just found out that the USB Xtractor doesn't work after the update.
     

Share This Page