1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with PSP 2.81

Discussion in 'Sony PSP - Mod and firmware discussion' started by romeo8627, Jul 14, 2007.

  1. romeo8627

    romeo8627 Member

    Joined:
    Jul 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Well, i got myself a PSP yesterday.. Since it was the last piece, i could get my hands only on 2.81..

    Now i have a few questions since am a complete n00b with PSP:

    1)I keep hearing about a n00b downgrader.. Where do i download one from?? I found its tutorials and video but no download link. Please help.. Thank you..

    2)I don't think i can afford a brick[ or a new PSP :-( ]. So if i keep my firmware as it is for few more months, how do i play games?? I mean, will ISOs work?? How to make them work??

    Please help me.. thanks to everybody.. :) :)
    Really appreciate it..
     
  2. RiPPERD

    RiPPERD Guest

    do u have GTA:LCS UNPATCHED (will say update version 2.00)

    or

    LUMINIES UNPATCHED??

    if not then DONT WHAT EVER YOU DO UPGRADE!!!!



    if u do then your ok if not then get a downgrader from www.psp-hacks.com

    and NO WHERE ELSE unless your 100% certain its real coz otherwise will brick your psp
     
  3. romeo8627

    romeo8627 Member

    Joined:
    Jul 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    First, thank you for helping me out.. :) :)

    No.. i don't have either.. i will have to search for it but it may take atleast a month to get it in my city..

    Am scared about bricking.. thats why am scared to downgrade.. Coz its costly for me and can't afford another one..


    I have few more doubts.. All these are related to non-genuine stuff(like ISOs and warez)..

    1)Does DevHook work with 2.81?? can i use it to play games without changing my firmware??


    2)Will PSX games (like PS1) run on 2.81.. I mean their ISOs.. If no, then what do i need to do??
    If yes, how do i do it?


    3)Can i play the ISO games without any UMD??

    Thanks a lot for helping me out so much.. really appreciate it.. :)
     
  4. mrmcman

    mrmcman Guest

    1) no
    2) no
    3) not yet, but u still need custom firmware.
     
  5. romeo8627

    romeo8627 Member

    Joined:
    Jul 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    thank you for helping out.. :)

    1)I just heard of DevHook Hybrid.. isn't that supposed to work with 2.81??

    2)For custom firmware, i will hv to downgrade to 1.5, right??

    3)What if i upgrade it to 3.03??

    4)what is the difference between 3.03, 3.03a, 3.03b, etc...??? Which is the best one??

    5)
    Among the above listed 3.03 versions, which one can be downgraded to 1.5 to run custom firmware??

    thanks a lot for helping me out in this matter.. :)
     
  6. mrmcman

    mrmcman Guest

    1) im pretty devhook hybrid is for 2.80 HEN or 2.71 HEN or 1.50, not 2.81.
    2)yes
    3)u have to go to 3.03 and downgrade with GTA LCS unpatched. unpatched has 2.00 update on it. ur only other option to downgrade is to go to 3.50 and use Lumines to downgrade.
    4)of the 3.03 custom firmwares, 3,03 oe-c is best. but there have since been better custom firmwares. the newest is 3.51 M33, which is wat i am now using. it is just like 3.03 oe-c. but, if u want the latest oe, then 3.40 oe-a is the way to go.
    5)every custom firmware (that i know about anyway...) have recovery mode, so they can all go back to 1.50 whenever u want.
     
    Last edited by a moderator: Jul 15, 2007
  7. RiPPERD

    RiPPERD Guest

    only thing u can do is upgrade to 3.03 or 3.50 and then downgrade and go from there

    no 2.81 downgraders
    no devhook to run above firmware 1.50 (except OE firmware but pointless)

    try renting gta lcs from rental shop but only use it to downgrade from 3.03 if its got an update file on it (VERSION 2.00)
     
  8. romeo8627

    romeo8627 Member

    Joined:
    Jul 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Thank you RiPPERED and mrmcman... :) :)

    I will search for GTA first.. i am not sure if its available in my city.. If not, i will try to upgrade to 3.50 and then use Lumines..

    I will post again after a day or two and before i do anything..

    Thanks a lot again.. :)
     
  9. RiPPERD

    RiPPERD Guest

    ... you mean RiPPER D

    and no prob mate if cant find it in shop try the internet
     
  10. pspfreak1

    pspfreak1 Regular member

    Joined:
    Mar 20, 2006
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    26
    romeo8627

    if i were you, this is what i'd do:

    get an unpatched version of GTA:LCS, downgrade ur psp to v 1.5 with the many tutorials on this very site. after downgrade, i'd upgrade to dark alex's 3.40 oe-a, and VOILA, u can play isos, just like u want.
     
  11. RiPPERD

    RiPPERD Guest

    have to disagree

    3.03OE-C better compatibility with plugins and customizing

     
  12. HMP24

    HMP24 Member

    Joined:
    Jul 15, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    How Exactly you can downgrade 3.03oe-c to 1.5 in the recovery mode, I´m new at this. Can you help me? And which is the best custom firmware for psp games (ISOs) emulation?
     
  13. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    Actually you can play PSX games on a version 2.81 but you have to download and buy them from the Playstation Store.
     
  14. HMP24

    HMP24 Member

    Joined:
    Jul 15, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    and in a custom firmware? I have heard about the 3.50 m33, i have the 3.03 oe-c which is better? because i have some problems with psp isos, maybe because some aren't compatible with the no-umd option. Am i right? And the i think i need the popstation to run the ps1 isos on a custom firmware. O-O
     
  15. RiPPERD

    RiPPERD Guest

    3.51 M33 is ok but not very compatible

    lots ppl said they upgraded and then gone back to 3.03OE-C / 3.40OE-A

    personally 3.03OE-C for me at moment

    but if u dont customise ya psp or use plugins then best for you will be 3.40OE-A

    i went back to 3.03OE-C to play GTA:LCS with the cheat device as it dont work past 3.03OE-C
     
  16. PSPslik

    PSPslik Member

    Joined:
    May 3, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    hi romeo8627!

    where you from?
    i have the same problem for more or less 3months now and i'm getting closer to what i, i mean WE, need the very rare GTA:LCS (Unpatched). That is our only hope dude...
     
  17. romeo8627

    romeo8627 Member

    Joined:
    Jul 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    oh.. am sorry... its RiPPER D...

    Thanks a for all the info.. :)

    I think i will go in for mainly games and less of customisation and stuff.. so shall i prefer 3.40 OE-A??


    @PSPslik
    Am from bangalore.. check ur message..
     
  18. romeo8627

    romeo8627 Member

    Joined:
    Jul 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Ok guys... Thanks a lot for all the help.. :)

    I found a guy and downgraded my PSP to 1.5 and then installed the custom firmware 3.40 OE-A... is this version fine??

    I heard the new M33 has some bugs still.. so i will wait for sometime before i jump onto that..

    I had a question. I need a UMD to play the game ISOs.. Is there anyway to disable that??

    Thanks..
     
  19. mrmcman

    mrmcman Guest

    no umd mode
     
  20. romeo8627

    romeo8627 Member

    Joined:
    Jul 14, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    thanks.. :

    Am not able to go into the recovery mode.. the screen just goes black with the green light still ON.. Does it take time to load the recovery more??

    Are there any requirements for it like battery should be above 75% or something like that??
     

Share This Page