1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Xenosaga episode i only has black screen and radar

Discussion in 'PS2 - DVD backup discussion' started by icefaii, Feb 19, 2008.

  1. icefaii

    icefaii Member

    Joined:
    Jul 11, 2007
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    16
    I got the 3 discs rip for xenosaga episode 1, and burned it onto the disc. It booted up properly, when when I select "new game", it just got into a black screen with a radar on the bottom right corner of the screen. I can go into character menu, but theres no characters. I waited for about 6 minutes and the screen is still black. I did some searching and found quite a few with the same problem. I found someone saying enabling mode 2 of ide hdd wil lwork, but my ps2 is slim and thus dont have ide hdd. What can I do to make it work? someone please help me.

    thanks in advance

    ps. I got a one disc version of xenosaga I and it yields the same result, booted up properly, but its black with with game radar when select new game..
     
  2. Newnie

    Newnie Regular member

    Joined:
    Dec 26, 2007
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    26
    im no expert but to me it sounds like a bad ISO on the disc. Try download another diffrent Image from another person or site and see if that works. but once again im no expert. im only tryna give out my thoughts since it seems like theres no help on this site wut so ever.
     

Share This Page