1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How can I play games that require to update on 1.50?

Discussion in 'Sony PSP - Games' started by attias6, Feb 11, 2007.

  1. attias6

    attias6 Guest

    Hi,

    I just bought a new PSP (yesterday. I bought the Entertainment Pack (ATV Offroad Furry Blazin' Trails, Lords of Dogtown, a 1GB Memory Stick Duo and it also came with the game LocoRoco (300$ Canadian).

    LocoRoco tells me I have to upgrade to 2.71 to play it but is there a way to play the game on 1.50 (Same thing with Grand Theft Auto: Liberty City Stories (makes me upgrade to 2.00))?

    Thank you
    Aviv
     
  2. vcbc

    vcbc Regular member

    Joined:
    Apr 15, 2006
    Messages:
    1,080
    Likes Received:
    0
    Trophy Points:
    46
    Theres a program called Devhook. Or you could install a custom firmware made by dark alex. The newest one is called 3.10 OE-A. It has all the features of 3.10 but also homebrew able. Look for these in a reliable site like. www.PSP-Hacks.com www.pspupdates.qj.net
     

Share This Page