1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I guess this is a laser problem?

Discussion in 'PS2' started by n00baveng, Feb 1, 2007.

  1. n00baveng

    n00baveng Member

    Joined:
    Feb 1, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Recently my modded PS2 has been making loud screetching sounds when playing games. It was more scary than deterimental since it never actually caused slow down or anything and it would only happen once every hour or so.

    But now... it's like it died. It boots up games 99% of the time without any problems, but after playing for about 15 minutes, it's like the laser just "gives up" and makes that repetive loud sound like it's trying to read something and failing and the game practically freezes. Though it's kind of weird how everything plays perfectly until that point...

    I imagine it's the laser, but it really sounds pretty bad. I think it may be dead. I was going to clean it later but I don't have any alcohol on hand, so I just thought I'd make a post here before I do anything. Q-tips with alchohol is alright for cleaning a laser right?

    But I'm kind of worried that cleaning the laser won't help me. This thing's dead huh...
     
  2. steimy

    steimy Active member

    Joined:
    Dec 2, 2004
    Messages:
    12,030
    Likes Received:
    1
    Trophy Points:
    96
    Q-tip with alcohol is fine. Just make sure you do not have the q-tip soaking wet where it could possibly drip. it just needs to be moist.

    as far as the loud skreetching i have no idea.
     
  3. MentalGuy

    MentalGuy Member

    Joined:
    Feb 2, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I am having the same problem. Only a few games work, while others will load the game but will freeze a few minutes into it. Also it is making a very loud noise, it sounds like scratching of the disc and if the disc was moving/skipping. I tried just cleaning the lens but it did not help. Does this mean there is something wrong with the laser or the modchip?
     

Share This Page