1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I have a problem with my modded Playstation2. Please help!!

Discussion in 'PS2' started by Robojack, Jun 20, 2003.

  1. Robojack

    Robojack Member

    Joined:
    Jun 20, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    I recently bought a modded Playstation2 (in February), and now I'm finding that certain copied DVDs play, and some don't. For example, some games load up just fine, while others take forever to load, and often skips like crazy (Dynasty Warriors 4 is ilke this, the music sometimes cuts off after a couple seconds of playing). However, if I reset a couple times, then MAYBE it'll start to work properly for a couple minutes, then start messing upu again. But like I said before, not all games are like this, only some of them. This problem started about a week ago, and before that, everything was working normally. I heard that the newer PS2's, such as mine, should be able to play all types media, good and bad.

    What can I do? I've cleaned my lens already through several methods, and retail (non-copied) games work just fine. Why is it that now, sometimes the backup games work and sometimes it doesn't (if i reset the system)? What's the problem behind this? I don't know what modchip I have, but it's one of the soldered ones. But in general, what could the problem be? Please respond ASAP, your help is greatly appreciated.
     
    Last edited: Jun 20, 2003
  2. Robojack

    Robojack Member

    Joined:
    Jun 20, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    Can someone please respond? Thanks.
     
  3. Icemonkey

    Icemonkey Active member

    Joined:
    Feb 28, 2003
    Messages:
    1,611
    Likes Received:
    0
    Trophy Points:
    66
    Sounds like a media problem if you already cleaned the lens. Try using higher quality blank DVD media and see if you get better results. Most people here prefer Verbatim and Ritek. It also has a lot to do with the version of PS2. The version 7's seem to be compatible with the most media. If that doesn't help, it might be the mod chip itself. I had lots of skip and game freeze problem when I had a Magic 3 which all went away when I upgraded to the Magic 3.1.
     

Share This Page