1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I have a PSP recently updated ¬.¬ but I have the original GTA:LCS

Discussion in 'Sony PSP - Mod and firmware discussion' started by jasonhuk, Jun 21, 2007.

  1. jasonhuk

    jasonhuk Member

    Joined:
    Jun 21, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    I'd really like to take my PSP down and get on the homebrew. I've read around and basically all I've found out is that as long as my brother stops updating there will probably be a downgrader available to me in a few years :p

    But I've read about Liberty Stories and I've just wanting to know if I can use that? I understand it had an update on it, so can I 'update' to old version? I'm not really understanding that side of it. Now I found that I can get hold of the original GTA I came back to this forum to ask what I could possibly do.

    Please could someone explain the GTA situation to me? I'd really like to get my PS1 games one the PSP. Thanks very much guys.

    Jas
     
  2. schism123

    schism123 Member

    Joined:
    Nov 18, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    16
    if your psp is above 3.03 it cant be downgraded at the moment, you just have to wait for the downgrader, the unpatched GTA game is for the 3.03 downgrader
     
  3. haasmon92

    haasmon92 Regular member

    Joined:
    Jun 4, 2007
    Messages:
    366
    Likes Received:
    0
    Trophy Points:
    26
    the 3.40 downgrader comes out in november of this year
     
  4. Karatekun

    Karatekun Member

    Joined:
    Apr 20, 2007
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    16
    There's no set date for downgraders. They come out when they're finished.
     
  5. jasonhuk

    jasonhuk Member

    Joined:
    Jun 21, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    thanks for the help, i think i'm at 4.1.. so I'm truly screwed. I hope I can hold my brother off updating for a good year! Jesus, it's so annoying!

    Are there really no workarounds?
     
  6. DoubleDwn

    DoubleDwn Regular member

    Joined:
    Sep 27, 2005
    Messages:
    877
    Likes Received:
    0
    Trophy Points:
    26
    4.1? Man you really are screwed, considering 3.5 is the highest official Sony firmware.

    ~Rich
     
  7. okthen12

    okthen12 Guest

    Lol 4.1 thats not even out yet.
    To find out your firmware go onto settings\systemsettings\system information (on your psp).
     
  8. jasonhuk

    jasonhuk Member

    Joined:
    Jun 21, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    HA well I've embarrassed myself! Don't even know what I was thinking of to be honest, I haven't picked the PSP in a while.

    Right so it's on 3.40 so I'll just have to wait.

    Now I'm going to look through every piece of software I have looking for a 4.10 so I know where I confused myself :p

    Cheers guys
     

Share This Page