1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

i know im probably saying this in the wrong forum but.....

Discussion in 'Sony PSP - Mod and firmware discussion' started by ultinator, Apr 26, 2007.

  1. ultinator

    ultinator Member

    Joined:
    Feb 20, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    basically my PSP is being very fudging poo if you get what i mean,
    i downgraded and devhooked it and it worked yada ya ....

    the weird thing is after a few weeks i couldnt play any of the downloaded games, after i investigated why it turns out that my PSP is not recognising actual UMD discs i put in, i mean i get the little symbol in the bottom right that says its reading the disc but it never quite gets past that point.

    i can still play iso's but i wanna play some other games i have on UMD that im struggling to find on the net.

    ====>1.5 firmware
    ====>3.03 Emulator
    ====>ISO works
    ====>UMD do not read at all.

    please help me i constantly find myself resorting to forums for assisstance for once i'd like to have everthing finally sorted out!
     
  2. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    maybe you have the umd start function off in the recovery menu, and as a tip bro, upgrade to 3.40 oe-a and leave devhook alone, its not worth the hassle
     

Share This Page