1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I NEED HELP

Discussion in 'Sony PSP - Mod and firmware discussion' started by sbandit, Jul 25, 2007.

  1. sbandit

    sbandit Guest

    Guys, i am a rookie user on the PSP... i have a US PSP with a official 3.40 firmware...
    Somebody please explain to me step by step, what i have to do to run ISO-s on my PSP...

    Thank you very much in advance... I appreciate it
     
  2. mrmcman

    mrmcman Guest

    1. upgrade to 3.50, not 3.51 or 3.52!! or u will be screwed!
    2. google and download the 3.50 downgrader
    4. go get Lumines unpatched (unpatched means any update apart from 3.51 on the disc)
    5. read the 3.50 downgrader readme, and use it. dont forget to get the 1.50 eboot, as the readme says
    6. upgrade to 3.51 M33 using the easy installer made on this site
    7. make an ISO folder on the root of ur memory stick, put ur iso'd there and run them from the game icon on the psp.
     
  3. sbandit

    sbandit Guest

    Thanks... One more question... What is this Lumines, and where can i download it, because i live in a shit hole country, in South east europe, where nobody heard of Lumines... Thank you one's more..

    P.S. Do you know the best and safest way to upgrade to 3.50 so i wont screw myself...
     
  4. mrmcman

    mrmcman Guest

  5. sbandit

    sbandit Guest

    So... if i dont get this Lumines game, there is no any other way...

    P.S. This is my last question BTW...

     
  6. mrmcman

    mrmcman Guest

    no. there is no other way.
     
  7. sbandit

    sbandit Guest

    I have also read somewhere that GTA Liberty City Stories can be used the same way as Lumines... Is this true ? Because i already have the GTA
     
  8. mrmcman

    mrmcman Guest

    it is used the same way, but is ffor the 3.03 downgrader. i told u, there is no other way to downgrade a 3.50. u need lumines.
     
  9. Dake_Karr

    Dake_Karr Member

    Joined:
    Apr 30, 2007
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    16
    Yes it can be used, BUT this is only for Official Sony FW's 3.03 and below, and that is only if you have an unptached GTA:LCS, and besides your on 3.40 so your SOL, just check ebay or amazon..they're out there....
     

Share This Page